Status

RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: armenzg, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
seta-dev currently has a 10k limit for rows.
Upgrading from free to basic will give us 10M rows.
This is a tier not as clearly publicized. It's about $500/year difference from the next level (Standard $50/m & Basic $9/month).

I've been following the instructions [1], however, I don't have enough privileges [2].
I've also tried through the UI, however, that requires adding my credit card.

Let me ask other Heroku admins.


[1] https://devcenter.heroku.com/articles/upgrading-heroku-postgres-databases#upgrade-with-pg-copy-default
[2]
armenzg@armenzg-thinkpad:~/repos$ heroku git:clone -a seta-dev
Cloning into 'seta-dev'...
remote: Counting objects: 1523, done.
remote: Compressing objects: 100% (706/706), done.
remote: Total 1523 (delta 939), reused 1299 (delta 786)
Receiving objects: 100% (1523/1523), 874.71 KiB | 1.17 MiB/s, done.
Resolving deltas: 100% (939/939), done.
Checking connectivity... done.
armenzg@armenzg-thinkpad:~/repos$ cd seta-dev/
armenzg@armenzg-thinkpad:~/repos/seta-dev$ heroku addons:create heroku-postgresql:basic
 !    That add-on plan is only available to select users.

Comment 1

2 years ago
(In reply to Armen Zambrano [:armenzg] - Engineering productivity from comment #0)
> This is a tier not as clearly publicized. It's about $500/year difference
> from the next level (Standard $50/m & Basic $9/month).

The plans are listed here:
https://elements.heroku.com/addons/heroku-postgresql#pricing

> I've been following the instructions [1], however, I don't have enough
> privileges [2].

Your account is an admin account, so already has maximum privileges.

I ran `heroku update` (just in case), then tried `heroku addons:create heroku-postgresql:basic -a seta-dev` and got the same error message.

I would imagine the problem is likely that an app cannot have two "hobby" (the "basic" plan is still a hobby plan) plans active at once. The guide you linked to is about switching from hobby -> non-hobby, not hobby -> hobby. However the error message is less than helpful.

I'd file a ticket against Heroku, asking what's up and if they could make the error message clearer:
https://help.heroku.com/tickets/new
(after filing, use the "share" button to add me)

> I've also tried through the UI, however, that requires adding my credit card.

That sounds like a bug - you shouldn't need a add a credit card for adding addons to a team app. Please mention this in the ticket to Heroku.

Comment 2

2 years ago
Oh strangely I was able to add another via the web UI. You can see it listed at:
https://dashboard.heroku.com/apps/seta-dev/resources

Still worth filing a Heroku ticket though.
(Reporter)

Comment 3

2 years ago
I used this command to copy the DB and promoting it [1]
The Charcoal DB now seems to have 6k+ records.
I can see that the free DB has been renamed to Onyx in the process.

I can see this working:
http://seta-dev.herokuapp.com/data/setadetails/?taskcluster=1&date=2016-07-20

[1]
armenzg@armenzg-thinkpad:~/repos/seta-dev$ heroku pg:copy DATABASE HEROKU_POSTGRESQL_CHARCOAL --app seta-dev

 !    WARNING: Destructive Action
 !    This command will remove all data from CHARCOAL
 !    Data from DATABASE will then be transferred to CHARCOAL
 !    This command will affect the app: seta-dev
 !    To proceed, type "seta-dev" or re-run this command with --confirm seta-dev

> seta-dev
Copy completed
armenzg@armenzg-thinkpad:~/repos/seta-dev$ heroku pg:promote HEROKU_POSTGRESQL_CHARCOAL
Ensuring an alternate alias for existing DATABASE... done, HEROKU_POSTGRESQL_ONYX
Promoting postgresql-clear-80792 to DATABASE_URL on seta-dev... done
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED

Comment 4

2 years ago
The former addon (now named Onyx) can be remove too I believe :-)
(Reporter)

Comment 5

2 years ago
Done.
You need to log in before you can comment on or make changes to this bug.