[e10s] Print to file silently fails

RESOLVED DUPLICATE of bug 1200593

Status

()

Core
Printing: Output
--
minor
RESOLVED DUPLICATE of bug 1200593
a year ago
a year ago

People

(Reporter: Berend De Schouwer, Unassigned)

Tracking

48 Branch
Unspecified
Linux
Points:
---

Firefox Tracking Flags

(e10s-)

Details

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:48.0) Gecko/20100101 Firefox/48.0
Build ID: 20160729072959

Steps to reproduce:

1. Go to a website
2. Print
3. Select "print to file"
4. Select a filename


Actual results:

A progress bar appears, disappears, and all appears OK


Expected results:

The file should be created (either .pdf or .ps)  No file was created.
(Reporter)

Comment 1

a year ago
This is new in 48.  It used to work in 47.

This is different from #1200593 and #415023 because Firefox has permissions to write to the specified location.  I've done this plenty times before, and it works in 47.  I've tried multiple locations (HOME, /tmp, other folders) to make sure.  I can download and save files in those locations.

Printing to a real printer, or a cups-pdf printer works.

This is on Linux (I assume the print system is somewhat OS-dependent.)
(Reporter)

Comment 2

a year ago
Appears to be a bug in e10s

Comment 3

a year ago
No problems in Firefox 48 when printing this very page to a PDF file under Fedora 24. 
Cannot reproduce.
(Reporter)

Comment 4

a year ago
Fedora 24 switches off e10s by default.  I don't know how to shift this report to e10s.
Severity: normal → minor
OS: Unspecified → Linux

Updated

a year ago
Summary: Print to file silently fails → [e10s] Print to file silently fails

Updated

a year ago
tracking-e10s: --- → ?

Updated

a year ago
Component: Untriaged → Printing: Output
Product: Firefox → Core

Updated

a year ago
Flags: needinfo?(twalker)
Berend,  are you see this with e10s enabled, with it disabled or both?
Flags: needinfo?(twalker) → needinfo?(berend.de.schouwer)
(Reporter)

Comment 6

a year ago
I only see the problem with e10s enabled.
Flags: needinfo?(berend.de.schouwer)
I think this is a dupe of something bob was working on related to printing.
Flags: needinfo?(bobowen.code)
(In reply to Jim Mathies [:jimm] from comment #7)
> I think this is a dupe of something bob was working on related to printing.

I'm not sure this is related, most of those have been Windows printing issues, but I'll see if I can reproduce.
I can't reproduce this in Fx48 on Ubuntu 12.04 with e10s forced on.
Flags: needinfo?(bobowen.code)
(Reporter)

Comment 10

a year ago
Apologies.  It's blocked by selinux.  I'll move it to Fedora.

So, two different problems
(a) silent fail is bad (see #1200593 and #415023)
(b) Fedora needs selinux updates.

Updated

a year ago
tracking-e10s: ? → -
(Reporter)

Comment 11

a year ago
Fedora bug https://bugzilla.redhat.com/show_bug.cgi?id=1370639 is open for selinux-policy

Trying to make this a duplicate of 1200593 since Firefox /should/ report an error.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1200593
You need to log in before you can comment on or make changes to this bug.