Location Bar height seems to be larger than Search Bar If Windows display font size was changed. So, bottom border line is missing in the Location Bar

RESOLVED WORKSFORME

Status

()

defect
P3
minor
RESOLVED WORKSFORME
3 years ago
2 years ago

People

(Reporter: alice0775, Unassigned)

Tracking

({regression})

42 Branch
x86
Windows 10
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox48 wontfix, firefox49 fix-optional, firefox-esr45 wontfix, firefox50 fix-optional, firefox51 fix-optional, firefox52 fix-optional)

Details

(Whiteboard: [fxprivacy])

Attachments

(1 attachment)

Posted image screenshot
See attached Screenshot

Steps To Reproduce:
1. Change text size of "Menus"
1-1. Open Control Panel > Appearance and Personalisation > Display
   (or Start > Settings > System > Display > Advances display settings > Advanced sizing of text and other items)
1-2. Select "Menus" and select "11" in "Change the text size only"
2 Launch Firefox

Actual Results:
LocationBar height seems to be larger than SerchBar

Expected results:
I think there is no reasons height difference between LocationBar and SearchBar
Sorry
1-2. Select "Message boxes" and select "11" in "Change the text size only"
Pretty sure this is a regression.
Priority: -- → P3
There are two regressions.

#1 Regression window about difference of height between LocationBar and SearchBar (Reproduced if the label is displayed in the identify box), but not truncated:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=d5727cb7221b&tochange=8f064c1c1d40

   Suspect : 9cd6b77fad86	Stephen Horlander — Bug 684450 - Remove stop/go/reload button affordance and streamline other location bar icons. r=dao


#2 Regression window about LocationBar bottom border truncated:
https://hg.mozilla.org/integration/fx-team/pushloghtml?fromchange=0366b96fc771&tochange=ce72fc6f687a

   Suspect : ce72fc6f687a	Paolo Amadini — Bug 1192434 - Adjust the vertical padding of the identity box across platforms. r=bgrins
Blocks: 684450
Thanks...
Has Regression Range: --- → yes
Summary: LocationBar height seems to be larger than SerchBar If Windows display font size was changed. So, bottom border line is missing in the LocationBar → Location Bar height seems to be larger than Search Bar If Windows display font size was changed. So, bottom border line is missing in the Location Bar
This looks like a minor polish issue. Paolo can you have a look ? We could still take a fix in aurora.
Currently the identity box is the element that sets the overall height of the location bar through the identity icons, but with non-default text sizes and the label visible, the text becomes larger and determines the new height.

I guess that we need to change things so that the main text area determines the height, and the icons and text in the identity box are just centered vertically. We would use the same margins for the main text in the search box so that they are always the same height.

Dão, how does it sound?

Either me or someone from our team might take care of this but it's likely a low priority ayways.
Flags: needinfo?(paolo.mozmail) → needinfo?(dao+bmo)
Whiteboard: DUPEME → [fxprivacy][triage]
Whiteboard: [fxprivacy][triage] → [fxprivacy]
Version: 49 Branch → 42 Branch
Looks like this may remain on a backlog for a while, but maybe it would make a good first bug.
It looks like this setting doesn't exist anymore on current Windows 10:

> 1-1. Open Control Panel > Appearance and Personalisation > Display
>    (or Start > Settings > System > Display > Advances display settings >
> Advanced sizing of text and other items)

However, I manually increased the text size with the Browser Toolbox and I can't seem to reproduce this bug anymore.
Flags: needinfo?(dao+bmo)
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.