Closed Bug 1293104 Opened 3 years ago Closed 3 years ago

Remove support for -forbid- lists in Seamonkey.

Categories

(SeaMonkey :: General, defect)

SeaMonkey 2.48 Branch
defect
Not set

Tracking

(seamonkey2.44 unaffected, seamonkey2.45 unaffected, seamonkey2.46 unaffected, seamonkey2.47 wontfix, seamonkey2.48 fixed)

RESOLVED FIXED
Tracking Status
seamonkey2.44 --- unaffected
seamonkey2.45 --- unaffected
seamonkey2.46 --- unaffected
seamonkey2.47 --- wontfix
seamonkey2.48 --- fixed

People

(Reporter: frg, Assigned: frg)

References

Details

Attachments

(2 files)

Bug 1274893 removed the forbid lists from Safe Browsing. It was not used because there was no ui for it in Seamonkey but it is now dead code and should be removed.
Just took out the parts which did go in with Bug 1250600.
Attachment #8778716 - Flags: review?(philip.chee)
Comment on attachment 8778716 [details] [diff] [review]
1293104-removeforbidlists.patch

r=Ratty a=Ratty
Attachment #8778716 - Flags: review?(philip.chee) → review+
c-a version for Seamonkey 2.47. Reviewed patch without string changes.

[Approval Request Comment]
Regression caused by (bug #): 1274893
User impact if declined: Just dead code.
Testing completed (on m-c, etc.): c-a 
Risk to taking this patch (and alternatives if risky): none.
String changes made by this patch: None. c-c String changes removed.
Attachment #8783224 - Flags: review+
Attachment #8783224 - Flags: approval-comm-aurora?
Comment on attachment 8783224 [details] [diff] [review]
1293104-removeforbidlists-ca.patch

shouldn't go in as per irc conversation.
Attachment #8783224 - Flags: review-
Attachment #8783224 - Flags: review+
Attachment #8783224 - Flags: approval-comm-aurora?
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Version: Trunk → SeaMonkey 2.48 Branch
You need to log in before you can comment on or make changes to this bug.