[E10S] Firefox 48 slow starting in Private Mode

RESOLVED INCOMPLETE

Status

()

RESOLVED INCOMPLETE
2 years ago
11 months ago

People

(Reporter: marcos_d2, Unassigned)

Tracking

({qawanted})

48 Branch
qawanted
Points:
---

Firefox Tracking Flags

(e10s+)

Details

(Whiteboard: triaged)

Attachments

(1 attachment, 1 obsolete attachment)

19.02 KB, text/plain
Details
(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:48.0) Gecko/20100101 Firefox/48.0
Build ID: 20160726073904

Steps to reproduce:

Right click in the taskbar icon > Open a new Private Window.


Actual results:

It takes 3 seconds in the white page then 2 seconds to load the "purple Private page" with E10S activated.

Without E10S it opens almost instantly.


Expected results:

Opening "Normal Mode" with E10S activated is as fast as with it not activated. "Private Mode" should behave the same way.

Updated

2 years ago
tracking-e10s: --- → ?
Marcos, can you reproduce in e10s in safe mode (with all add0ons disabled?)

This WFM on on Mac 10.11 with latest Nightly 51.0a1, 20160811030201 (Multiprocess Windows : 1/1 (Enabled by default))
(Reporter)

Comment 2

2 years ago
When I start Firefox in Private Mode + Safe Mode (all addons disabled) the issue DOES NOT occur.

When I create a new clean profile, change ONLY the parameters below of 'about:config' and close/start it in Private Mode the issue OCCURS:
   browser.tabs.remote.autostart=true
   extensions.e10sBlockedByAddons=false
   extensions.e10sBlocksEnabling=false
   browser.tabs.remote.force-enable=true
Marcos, thanks for checking.  This is likely caused by an add-on, please attach your about:support
Blocks: 905436
tracking-e10s: ? → +
(Reporter)

Comment 4

2 years ago
Created attachment 8780209 [details]
2016-08-11_about_config.txt

I uninstalled "Free Memory 2.0" addon and it got 1~2 seconds faster to start, although it's slower than 'Normal Mode' with or without the addon installed.

about:support attachment: 2016-08-11_about_config.txt.

Comment 5

2 years ago
Marcos, is there any chance you could try narrowing it down to one addon?
(Reporter)

Comment 6

2 years ago
Uninstalling AdBlock Plus makes it 0.5 ~ 1.0 second faster to start
the browser in Private Mode. I couldn't disable Kaspersky Addon.

With all addons, including Free Memory 2.0, it opens instantly in
'Normal Mode'.

Comment 7

2 years ago
can QA test adblock plus in private browsing mode (latest version).  shouldn't be suspect - but validate.

then kapersky
Keywords: qawanted

Updated

2 years ago
Whiteboard: triaged

Comment 8

2 years ago
User Agent 	Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:48.0) Gecko/20100101 Firefox/48.0
Build ID	20160726073904

Hi, 

I tried to reproduce the issue with AdBlock Plus 2.7.3 installed but it worked fine for me. I also installed Free Memory 2.0 add-on but still I could not reproduce the issue. 
I wanted to check Kaspersky too, but I could not find the addon, I guess Kaspersky antivirus has to be installed on the machine previously (privilege that I don't have).

I have tried on Firefox 48 (pt-BR) and Firefox 49.0.1 (en-US) on Windows 7 x64 with the preferences from comment 2.

Comment 9

2 years ago
Marcos, can you still reproduce the issue on latest release (49.0.1) or latest Nightly [1]?
[1] https://nightly.mozilla.org/
(Reporter)

Comment 10

2 years ago
Created attachment 8801115 [details]
2016-08-11_about_support.txt

Firefox 49.0.1:
* Private Mode: takes about 3 seconds to be able to type on address bar;
* Normal Mode: takes almost 2 seconds to be able to type on address bar.
(Reporter)

Comment 11

2 years ago
Comment on attachment 8780209 [details]
2016-08-11_about_config.txt

Marked as obsolete because there's a new updated attachment regarded to about:support information.
Attachment #8780209 - Attachment is obsolete: true

Updated

2 years ago
Component: Untriaged → Extension Compatibility
With Firefox 57 only WebExtensions are permitted and are, by default, e10s compatible.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 months ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.