Bug 1293367 (SQLite3.14.1)

Upgrade to SQLite 3.14.1

RESOLVED FIXED in Firefox 51

Status

()

defect
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: ionnv, Assigned: RyanVM)

Tracking

unspecified
mozilla51
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox51 fixed)

Details

()

Attachments

(1 attachment)

https://www.sqlite.org/news.html

https://www.sqlite.org/releaselog/3_14.html

SQLite version 3.14 (the "π" release) is a regularly scheduled maintenance release containing performance enhancements, new features, and fixes for obscure bugs.
Depends on: SQLite3.13.0
SQLite Release 3.14.1 On 2016-08-11

- A performance enhancement to the page-cache "truncate" operation reduces COMMIT time by dozens of milliseconds on systems with a large page cache.
- Fix to the --rbu option of sqldiff.
Alias: SQLite3.14.0 → SQLite3.14.1
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Upgrade to SQLite 3.14.0 → Upgrade to SQLite 3.14.1
Try looks good. Since mak is on PTO, can you rubberstamp this, Andrew?
Attachment #8782715 - Flags: review?(bugmail)
Comment on attachment 8782715 [details] [diff] [review]
Upgrade SQLite to version 3.14.1

Thanks for this!  Assuming it sticks, it will let us fix bug 835796 and make the memory reporters very happy.
Attachment #8782715 - Flags: review?(bugmail) → review+
Blocks: 835796
https://hg.mozilla.org/mozilla-central/rev/e0fde5087c37
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla51
Blocks: 1285041
SQLite 3.14.2 was released a couple days ago.

https://www.sqlite.org/releaselog/3_14_2.html
Y'all are welcomed to upgrade to 3.14.2 if you like, and we will help you with that in any way we can.  But, honestly, I don't think it will be important to you.
If there's nothing relevant to Firefox in that update, I'm perfectly content waiting for the next major release. Thanks for chiming in, Richard!
Blocks: SQLite3.15.0
You need to log in before you can comment on or make changes to this bug.