900 instances of "Suboptimal indexes for the SQL statement 0x7fdc6dc3d420 (http://mzl.la/1FuID0j)." emitted from storage/mozStoragePrivateHelpers.cpp during linux64 debug testing

RESOLVED DUPLICATE of bug 1293375

Status

()

defect
RESOLVED DUPLICATE of bug 1293375
3 years ago
3 years ago

People

(Reporter: erahm, Unassigned)

Tracking

(Blocks 1 bug)

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

> 884 WARNING: Suboptimal indexes for the SQL statement 0x7fdc6dc3d420 (http://mzl.la/1FuID0j).: file storage/mozStoragePrivateHelpers.cpp, line 114

This warning [1] shows up in the following test suites:

>    884 - desktop-test-linux64/debug-web-platform-tests-5 5

It shows up in 605 tests. A few of the most prevalent:

>    121 -        /html/semantics/document-metadata/the-meta-element/pragma-directives/attr-meta-http-equiv-refresh/parsing.html
>     25 -        /html/infrastructure/urls/resolving-urls/query-encoding/utf-16le.html
>     25 -        /html/infrastructure/urls/resolving-urls/query-encoding/windows-1252.html
>     25 -        /html/infrastructure/urls/resolving-urls/query-encoding/utf-8.html
>     25 -        /html/infrastructure/urls/resolving-urls/query-encoding/windows-1251.html
>      5 -        /html/semantics/embedded-content/the-img-element/sizes/parse-a-sizes-attribute.html
>      5 -        /html/semantics/scripting-1/the-template-element/definitions/template-contents.html
>      4 -        /html/semantics/forms/form-submission-0/url-encoded.html
>      4 -        /html/semantics/document-metadata/the-base-element/base_multiple.html
>      4 -        /html/semantics/scripting-1/the-template-element/template-element/template-descendant-frameset.html

[1] https://hg.mozilla.org/mozilla-central/annotate/e78975b53563/storage/mozStoragePrivateHelpers.cpp#l114
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1293375
You need to log in before you can comment on or make changes to this bug.