Closed Bug 1293377 Opened 3 years ago Closed 3 years ago

900 instances of "Suboptimal indexes for the SQL statement 0x7f5e8a93f080 (http://mzl.la/1FuID0j)." emitted from storage/mozStoragePrivateHelpers.cpp during linux64 debug testing

Categories

(Toolkit :: Storage, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1293375

People

(Reporter: erahm, Unassigned)

References

(Blocks 1 open bug)

Details

> 884 WARNING: Suboptimal indexes for the SQL statement 0x7f5e8a93f080 (http://mzl.la/1FuID0j).: file storage/mozStoragePrivateHelpers.cpp, line 114

This warning [1] shows up in the following test suites:

>    884 - desktop-test-linux64/debug-web-platform-tests-e10s-5 5

It shows up in 605 tests. A few of the most prevalent:

>    121 - [e10s] /html/semantics/document-metadata/the-meta-element/pragma-directives/attr-meta-http-equiv-refresh/parsing.html
>     25 - [e10s] /html/infrastructure/urls/resolving-urls/query-encoding/utf-16le.html
>     25 - [e10s] /html/infrastructure/urls/resolving-urls/query-encoding/windows-1252.html
>     25 - [e10s] /html/infrastructure/urls/resolving-urls/query-encoding/windows-1251.html
>     25 - [e10s] /html/infrastructure/urls/resolving-urls/query-encoding/utf-8.html
>      5 - [e10s] /html/semantics/scripting-1/the-template-element/definitions/template-contents.html
>      5 - [e10s] /html/semantics/embedded-content/the-img-element/sizes/parse-a-sizes-attribute.html
>      4 - [e10s] /html/semantics/scripting-1/the-template-element/template-element/node-document-changes.html
>      4 - [e10s] /html/semantics/scripting-1/the-template-element/template-element/template-descendant-frameset.html
>      4 - [e10s] /html/semantics/embedded-content/the-iframe-element/change_parentage.html

[1] https://hg.mozilla.org/mozilla-central/annotate/e78975b53563/storage/mozStoragePrivateHelpers.cpp#l114
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1293375
You need to log in before you can comment on or make changes to this bug.