Remove special chars from POP server User Name & can't login (i.e. @, :, #)

VERIFIED FIXED in mozilla1.0

Status

SeaMonkey
MailNews: Account Configuration
P2
normal
VERIFIED FIXED
16 years ago
14 years ago

People

(Reporter: Ninoschka Baca, Assigned: Cavin Song)

Tracking

Trunk
mozilla1.0
x86
Windows ME

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
Trunk build 2002-05-06: WinMe

Overview: In the Account Wizard create a POP account and enter a special 
character (i.e. @, #) in the User Name text box. In Account Settings try to fix 
the mistake and you will be unable to login to the acccount

Found this bug while checking bug# 111478.

Steps to reproduce:
1. Open the Account Wizard to create a POP account
2. In the Account Wizard's User Name dialog enter a User Name that includes 
special characters such as "@", "#" or ":". (i.e. qatest22@)
3. After the Account Wizard is closed, Get Messages and literally nothing 
happens. No error message, nothing.
4. Open Account Settings, go to the Server Settings panel and edit the User Name 
to make it correct (i.e. qatest22)
5. After closing Account Settings, Get Messages 

Actual Results: Nothing happens, no error message, literally no response.
I checked the POP Server settings again and it displays "qatest22" as 
expected. After an exit/restart still nothing happens if you try to login.

I'll attach my prefs.js file to show how the file is not updated correctly. For 
intance:
user_pref("mail.server.server1.realuserName", "qatest32");
user_pref("mail.server.server1.userName", "qatest32@");

Expected Results: After correcting the User Name I should be able to retrieve 
messages.

Additional Information:
- In step# 2 if I enter numbers or alpha characters (i.e. qatest22abcd1234), 
then make the correction (i.e. qatest22) then I can retrieve messages and use 
the account as expected.
(Reporter)

Comment 1

16 years ago
Marking nsbeta1 for consideration. 

- POP and IMAP prefs both look bad but POP is a special case because you are not 
able to retrieve messages. IMAP must go through a different scenario because I 
am able to retrieve messages.

- If the account was created correctly in the Account Wizard then I can get back 
into a state where I can receive messages. So maybe the problem only occurs when 
the special character (@) is entered in the Account Wizard.

---------------------------------------------------------------------
The following are more details in profiles where the account was created 
correctly in the Account Wizard:

- exit/restart, now if I change the User Name to include an "@" (qatest22@), 
ofcourse it fails to login, but after editing the User Name and correcting it 
(i.e. qatest22), I can login and retrieve messages.

- and in the same session I edit the account to include an "@", then change it 
back to a correct settings, again I can login and retrieve messages.
Keywords: nsbeta1
(Reporter)

Comment 2

16 years ago
Created attachment 72909 [details]
prefs.js: displays problem with userName and realuserName being different

Comment 3

16 years ago
reassigning to cavin.  My concern with this bug would be that someone would type
in something like scottip@netscape.com and then go and change it to scottip and
then have it not work.
Assignee: racham → cavin
Keywords: nsbeta1 → nsbeta1+
Priority: -- → P2
Target Milestone: --- → mozilla1.0
(Reporter)

Updated

16 years ago
Summary: Remove special chars from POP server User Name & can't login → Remove special chars from POP server User Name & can't login (i.e. @, :, #)

Comment 4

16 years ago
manually editing .username allows me to get my bugzilla spam again. :-)
(Assignee)

Comment 5

16 years ago
Using 2002031203 build I could not reproduce the problem because I was able to 
see the login dialog and everything worked as expected.  The login dialog even 
showed the exact user name that I entered (ie, two @s) like the following:

   Enter your password for qatest22@@netscape.com

I restarted the mail program and it worked fine/as expected as well. 
Corrected the username from Account Settings|Server Settings and was able to 
log into the server and retrieved the msgs.

Bernd, can you try the latest build and see if you can reproduce the problem? 
Thanks.

Comment 6

16 years ago
wfm this was fixed by Darin's checkin for bug 129539
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
(Reporter)

Comment 7

16 years ago
Trunk build 2002-03-22: WinMe, Linux RH 7.1, Mac 10.1.3
Verified Fixed.

I opened another bug for a specific linux problem where it crashes after
cancelling the password dialog (bug# 133037).
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.