'allow pasting' must be typed into the developer tools in every new private browsing session

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
2 years ago
2 months ago

People

(Reporter: shane, Unassigned)

Tracking

48 Branch

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:48.0) Gecko/20100101 Firefox/48.0
Build ID: 20160728204513

Steps to reproduce:

In a normal browsing window, open the firefox developer tools and go to the console tab. Try to paste something into the console e.g. 
console.log("Hello");
Type 'allow pasting' so that you can paste into the console.
Open a private browsing session, open the firefox developer tools and go to the console tab. Try to paste something into the console e.g. 
console.log("Hello");


Actual results:

Scam warning appears about pasting and you must type 'allow pasting' to paste into the console. 

This occurs every time a new private browsing session is opened and can be very annoying while doing debugging and development.


Expected results:

The warning should not show up as it has already been shown that the user knows what they are doing with the developer tools in normal browsing.
(Reporter)

Updated

2 years ago
Component: Untriaged → Developer Tools: Console
I've just tested following the STR and I'm not seeing the warning in a private window after typing 'allow pasting' in the normal window.  They should be sharing the `devtools.selfxss.count` that controls this behavior.  Can you reproduce this in a clean profile?  If so, what value do you see for devtools.selfxss.count in both the normal and private window?
Flags: needinfo?(shane)
Resolving as worksforme since there hasn't been another report of this.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 months ago
Flags: needinfo?(shane)
Resolution: --- → WORKSFORME

Updated

2 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.