Enforce that all places items must have non-null GUIDs

RESOLVED DUPLICATE of bug 1294291

Status

()

RESOLVED DUPLICATE of bug 1294291
2 years ago
2 years ago

People

(Reporter: markh, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
Places goes to great lengths to ensure all items have GUIDs, and has a "unique" index on the column. It has DEBUG-only code in Database::Shutdown() that asserts if it finds any NULL items, but best I can tell, this isn't actually enforced.

Doing this would allow Sync to remove some complexity around ensuring items have GUIDs when best I can tell, that's already true, just not enforced.

ISTM this might be as easy as changing the GUID column to be "NOT NULL"?

Mak, is there something I'm missing here?
(Reporter)

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1294291
You need to log in before you can comment on or make changes to this bug.