Page titles with emoji might get wrongly ellipsised

RESOLVED DUPLICATE of bug 1164759

Status

()

Firefox
Tabbed Browser
RESOLVED DUPLICATE of bug 1164759
2 years ago
2 years ago

People

(Reporter: sole, Unassigned)

Tracking

({DevAdvocacy})

Trunk
Unspecified
Mac OS X
DevAdvocacy
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

Created attachment 8780115 [details]
Screen Shot 2016-08-11 at 15.31.33.png

I have a suspicion that the text-shortening algorithm is using just byte/string length and not "wide character" or unicode length, which is why sometimes unicode characters get split in half as in the case in the screenshot where it says "
(Reporter)

Comment 1

2 years ago
Forgot to say I'm using a fresh 20160811 Nightly on Mac OS X el capitan on a retina MacBook
OS: Unspecified → Mac OS X
Version: unspecified → Trunk
Yep, we know about this. Unfortunately, I'm not aware of anybody on the core team working on this. :-(
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1164759
You need to log in before you can comment on or make changes to this bug.