Closed Bug 129456 Opened 21 years ago Closed 21 years ago

autoreg chrome instead of using REGCHROME

Categories

(SeaMonkey :: Build Config, defect, P1)

defect

Tracking

(Not tracked)

RESOLVED FIXED
mozilla1.0

People

(Reporter: netscape, Assigned: netscape)

References

Details

Attachments

(2 files, 2 obsolete files)

Bryner pointed out that we register the chrome when we create the jarfiles on
the mac.  We should do the same thing on unix & win32 as well. It would remove
the need for all of those @$(REGCHROME) calls from the Makefiles (removing the
need to duplicate them for the 'make install' step as well).
Blocks: 56601
Status: NEW → ASSIGNED
Keywords: mozilla1.0
Priority: -- → P1
Target Milestone: --- → mozilla1.0
*** Bug 129453 has been marked as a duplicate of this bug. ***
*** Bug 129454 has been marked as a duplicate of this bug. ***
*** Bug 129455 has been marked as a duplicate of this bug. ***
Summary: remove REGCHROME → autoreg chrome instead of using REGCHROME
Ok, so what I discovered is that our chrome reg isn't sync'd to the presence of
a jar file in all cases.  Specifically, all the platform locale specific jar
files under xpfe/{browser,communicator,global} do not need to be registered;
only the jar file for the current platform needs to be registered.  So I added
a NO_JAR_AUTO_REG=1 to the build to get around that problem and left the
REGCHROME entries that reference those platform specific bits in the Makefiles.
 The mac seems to get around this problem by ordering the build but since we
support parallel (-j) builds, that isn't going to work for us.
Attachment #73099 - Attachment is obsolete: true
Comment on attachment 73438 [details] [diff] [review]
Autoregister chrome contents.rdf entries except when NO_JAR_AUTO_REG is set in the makefiles

r=bryner if you remove the extra \ on the first line of the RegIt function.
Attachment #73438 - Flags: review+
Comment on attachment 73439 [details] [diff] [review]
Remove REGCHROME entries from rest of Makefile.{,w}ins

r=bryner
Attachment #73439 - Flags: review+
Comment on attachment 73438 [details] [diff] [review]
Autoregister chrome contents.rdf entries except when NO_JAR_AUTO_REG is set in the makefiles

a=asa (on behalf of drivers) for checkin to the 1.0 trunk
Attachment #73438 - Flags: approval+
Comment on attachment 73439 [details] [diff] [review]
Remove REGCHROME entries from rest of Makefile.{,w}ins

a=asa (on behalf of drivers) for checkin to the 1.0 trunk
Attachment #73439 - Flags: approval+
Patch has been checked in.
Status: ASSIGNED → RESOLVED
Closed: 21 years ago
Resolution: --- → FIXED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.