Share modules with the rest of devtools

RESOLVED DUPLICATE of bug 1301487

Status

P1
normal
RESOLVED DUPLICATE of bug 1301487
2 years ago
3 months ago

People

(Reporter: jlong, Assigned: jlong)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

2 years ago
In the new debugger bundle, we shouldn't be bundling in a lot of stuff like codemirror and react. This will reduce our bundle size greatly and make sure we are compatible with the rest of devtools.
(Assignee)

Updated

2 years ago
Blocks: 1294139
(Assignee)

Comment 1

2 years ago
Also see bug 1294738 for the reported size regression
(Assignee)

Updated

2 years ago
Assignee: nobody → jlong
(Assignee)

Updated

2 years ago
Blocks: 1295318
(Assignee)

Updated

2 years ago
No longer blocks: 1295318
Depends on: 1295318
James, are you actively working on this? It seems like this bug should be triaged as P1.

Updated

2 years ago
Priority: -- → P1
Status: NEW → ASSIGNED
(Assignee)

Updated

2 years ago
Depends on: 1301487
(Assignee)

Comment 3

2 years ago
Let's just make this a dupe, as it will happen in the next debugger update.
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1301487

Updated

2 years ago
No longer depends on: 1301487

Updated

3 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.