Closed Bug 1294841 Opened 4 years ago Closed 4 years ago

Focus ring appears around the viewport

Categories

(DevTools :: Responsive Design Mode, defect, P1)

defect

Tracking

(firefox51 verified)

VERIFIED FIXED
Firefox 51
Iteration:
51.2 - Aug 29
Tracking Status
firefox51 --- verified

People

(Reporter: jryans, Assigned: jryans)

References

Details

(Whiteboard: [multiviewport][reserve-rdm])

Attachments

(2 files)

Attached image Undesired Focus Ring
This seems tied to a relatively recent CSS change elsewhere in DevTools.  The viewport now gets a focus outline around it if you click anywhere inside the viewport.  Also, the blue selection markers appear at the bottom left and right corner of the viewport.

Something like the following CSS change should fix it:

.browser {
  display: block;
  border: 0;
  -moz-user-select: none;
}

.browser:-moz-focusring {
  outline: none;
}
Flags: qe-verify+
Iteration: --- → 51.1 - Aug 15
Priority: P3 → P1
QA Contact: mihai.boldan
Iteration: 51.1 - Aug 15 → 51.2 - Aug 29
Flags: qe-verify+ → qe-verify-
:bgrins, this seems like it appeared recently due to some surrounding DevTools accessibility CSS changes, and I've noticed you reviewing some of those, so you seemed like a good choice.

To check it out in new RDM, set devtools.responsive.html.enabled to true and restart Firefox before opening RDM.
Comment on attachment 8781819 [details]
Bug 1294841 - Remove selection and focus ring from RDM browser.

https://reviewboard.mozilla.org/r/72146/#review70022

This seems fine
Attachment #8781819 - Flags: review?(bgrinstead) → review+
Pushed by jryans@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/30da32629a3c
Remove selection and focus ring from RDM browser. r=bgrins
https://hg.mozilla.org/mozilla-central/rev/30da32629a3c
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 51
I have reproduced this bug using the instruction from comment #2 with Nightly 51.0a1 (2016-08-13) on Elementary OS 64bit. 

This bug's fix is now verified on Latest Nightly 51.0a1

build id 	20160901030202
user agent	Mozilla/5.0 (X11; Linux x86_64; rv:51.0) Gecko/20100101 Firefox/51.0

[bugday-20160831]
QA Contact: mihai.boldan
Status: RESOLVED → VERIFIED
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.