Closed Bug 1294887 Opened 4 years ago Closed 3 years ago

Middle clicking search results does not open a new tab

Categories

(Firefox :: Search, defect, P1)

51 Branch
x86_64
All
defect

Tracking

()

VERIFIED FIXED
Firefox 52
Tracking Status
firefox48 --- unaffected
firefox49 --- unaffected
firefox50 --- unaffected
firefox51 --- verified
firefox52 --- verified

People

(Reporter: xenotoad, Assigned: adw)

References

Details

(Keywords: regression, Whiteboard: [fxsearch])

Attachments

(2 files)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:51.0) Gecko/20100101 Firefox/51.0
Build ID: 20160812030200

Steps to reproduce:

Enter a few terms into the search box in the upper-right and middle-click one of the results.


Actual results:

The search box disappeared for a little bit when I released the middle-click.


Expected results:

The search result should be opened in a new tab and the search box should not disappear.
OS: Unspecified → Linux
Hardware: Unspecified → x86_64
Component: Untriaged → Search
I think we could use some help here to triage, eg. to answer the following questions:
- can someone else reproduce?
- Is this Linux-specific, or on all platforms?
- Is it a regression or has it always been this way?
Hi, 

I reproduce this on Windows 10, so it's not Linux only and it is a regression. 

Pushlog: https://hg.mozilla.org/integration/fx-team/pushloghtml?fromchange=46045ec8a4aa09a341b7209170089ade3c27c1a5&tochange=555caa0082c342c60830261ecba4c4068122207e

Regressed by bug 1180944 (MozReview-Commit-ID: A9YXB32L7MN).
Blocks: 1180944
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
Keywords: regression
Priority: -- → P1
Whiteboard: [fxsearch]
Hi :adw,
Since you fixed bug 1180944, could you help to take a look at this one?
Flags: needinfo?(adw)
Yep, I'll look at this one along with the other regressions.
Assignee: nobody → adw
Status: NEW → ASSIGNED
Flags: needinfo?(adw)
Possible dupe / same cause as bug 1296366?
Thanks for filing this.  As far as I can tell, the popup always closed and then quickly reopened, so I think this is only really about the tab not properly loading in the background.

Florian, I removed the "tab-background" option for `where` in the urlbar one-offs bug since it was kind of non-standard (i.e., something not returned by whereToOpenLink IIRC), in favor of the more-standard "tab" plus params.inBackground.  This is one place in urlbarBindings that was still using tab-background.  I searched dxr for tab-background and there are no more instances.
Comment on attachment 8801457 [details]
Bug 1294887 - Middle clicking search results does not open a new tab.

https://reviewboard.mozilla.org/r/86208/#review85582

The patch looks reasonable. It's disappointing this regression wasn't caught by a test.
Attachment #8801457 - Flags: review?(florian) → review+
Pushed by dwillcoxon@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/545b89141c83
Middle clicking search results does not open a new tab. r=florian
https://hg.mozilla.org/mozilla-central/rev/545b89141c83
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 52
Hi :adw,
Can you help create a uplift request for 51 aurora?
Flags: needinfo?(adw)
I have reproduced this bug with Nightly 51.0a1 (2016-08-12) on Windows 7 , 64 Bit !

This bug's fix is verified with latest Nightly 

Build ID    : 20161019030208
User Agent  : Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:52.0) Gecko/20100101 Firefox/52.0
[bugday-20161019]
Attached patch Aurora 51 patchSplinter Review
Approval Request Comment
[Feature/regressing bug #]: One-off searches in the urlbar, bug 1180944
[User impact if declined]: Middle-clicking search results will not open them in a new tab
[Describe test coverage new/current, TreeHerder]: Manual testing
[Risks and why]: Low risk, small patch
[String/UUID change made/needed]: None
Flags: needinfo?(adw)
Attachment #8802645 - Flags: approval-mozilla-aurora?
Comment on attachment 8802645 [details] [diff] [review]
Aurora 51 patch

Fix a regression related to urlbar. Take it in 51 aurora.
Attachment #8802645 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
For Nightly 52 the fix is also verified on Mac 10.11 and Ubuntu 16.04.

For Aurora 51 (Build ID 20161021004016) the fix is verified on Windows 10, Mac 10.11 and Ubuntu 16.04.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.