File (local filesystem) browsing not functioning

RESOLVED DUPLICATE of bug 13607

Status

()

Core
Networking: File
RESOLVED DUPLICATE of bug 13607
16 years ago
16 years ago

People

(Reporter: Norman B. Robinson, Assigned: asa)

Tracking

({verifyme})

Trunk
x86
Windows 98
verifyme
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
Behavior of Netscape for URL: file:/// is to browse the local filesystem.
Mozilla version Mozilla 0.9.9 Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.9)
Gecko/20020305 does not support this behavior. Nor does it support any
subdirectory specification. Since it does support opening of local files (html,
jpg, recongnized filetypes) I believe this functionality should be present but
is not. I searched for bugs and implementation specs before submitting this
report to no avail.
To reproduce this 'bug' simply type in any file:/// in the URL bar. Also note
behaviour by comparing the opening of any completely specified file (i.e.,
file:///c:/tmp/mypic.jpg)

Comment 1

16 years ago
With build ID 2002030604 win2000, browsing file:/// does nothing, but browsing
subdirectories like file://C:/ works fine.

*** This bug has been marked as a duplicate of 127408 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 3

16 years ago
+qawanted (need to clarify problem), verifyme (dupe of one bug or another...)
Norman:

Are you asking for file:/// to display something, or are you saying that some
file URL's that used to work stopped working recently? These are different bugs...

Component: Browser-General → Networking: File
Keywords: verifyme
QA Contact: doronr → benc

Comment 4

16 years ago
this bug is asking for file:/// to work in Windows....
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 5

16 years ago
RESOLVED/DUPE:
reporter, please look at the other bug, and mark this verified if this is the
problem you were concerned with.

*** This bug has been marked as a duplicate of 13607 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.