Closed Bug 1294937 Opened 3 years ago Closed 3 years ago

The context menu does not appear when right-click on the inspector-searchbox

Categories

(DevTools :: Inspector, defect, P1)

defect

Tracking

(firefox50 unaffected, firefox51 verified)

VERIFIED FIXED
Firefox 51
Iteration:
51.2 - Aug 29
Tracking Status
firefox50 --- unaffected
firefox51 --- verified

People

(Reporter: magicp.jp, Assigned: gasolin)

References

Details

(Whiteboard: [reserve-html])

Attachments

(2 files)

User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:51.0) Gecko/20100101 Firefox/51.0
Build ID: 20160812030200

Steps to reproduce:

1. Start Nightly
2. Open DevTools > Inspector
3. Right-click on inspector-searchbox


Actual results:

The context menu does not appear when right-click on the inspector-searchbox.

Regression range:
https://hg.mozilla.org/integration/fx-team/pushloghtml?fromchange=c9bbdb627b7804fee47aa6a6708647e6e589d09c&tochange=3269dd1a824d1b42cb021d1fb6858885179940b0




Expected results:

The context menu works on the inspector-searchbox.
Blocks: 1265759
Has Regression Range: --- → yes
Has STR: --- → yes
Component: Untriaged → Developer Tools: Inspector
OS: Unspecified → All
Hardware: Unspecified → All
Flags: qe-verify?
Whiteboard: [devtools-html] [triage]
Assignee: nobody → gasolin
Status: NEW → ASSIGNED
Flags: qe-verify? → qe-verify+
Priority: -- → P3
QA Contact: cristian.comorasu
Whiteboard: [devtools-html] [triage] → [reserve-html]
Comment on attachment 8780970 [details]
Bug 1294937 - The context menu does not appear when right-click on the inspector-searchbox;

https://reviewboard.mozilla.org/r/71484/#review69248
Thanks for provide good examples! I modified them and test seems works well
Comment on attachment 8780970 [details]
Bug 1294937 - The context menu does not appear when right-click on the inspector-searchbox;

https://reviewboard.mozilla.org/r/71484/#review69502

::: devtools/client/inspector/test/browser_inspector_search-filter_context-menu.js:6
(Diff revision 3)
> +/* vim: set ft=javascript ts=2 et sw=2 tw=80: */
> +/* Any copyright is dedicated to the Public Domain.
> +   http://creativecommons.org/publicdomain/zero/1.0/ */
> +"use strict";
> +
> +// Test main search filter context menu works properly.

Should clarify that this is testing the inspector's markup view search filter context menu

::: devtools/client/inspector/test/browser_inspector_search-filter_context-menu.js:10
(Diff revision 3)
> +
> +// Test main search filter context menu works properly.
> +
> +const TEST_INPUT = "h1";
> +const TEST_URI = "data:text/html;charset=utf-8," +
> +  encodeURIComponent("<h1>test filter context menu</h1>");

I usually prefer seeing:
yield addTab("data:text/html;charset=utf-8," + encodeURIComponent(TEST_URI));

That way we can keep the HTML separate from the data:text/html protocol string.

::: devtools/client/inspector/test/browser_inspector_search-filter_context-menu.js:13
(Diff revision 3)
> +const TEST_INPUT = "h1";
> +const TEST_URI = "data:text/html;charset=utf-8," +
> +  encodeURIComponent("<h1>test filter context menu</h1>");
> +
> +add_task(function* () {
> +

Remove empty line

::: devtools/client/inspector/test/browser_inspector_search-filter_context-menu.js:14
(Diff revision 3)
> +const TEST_URI = "data:text/html;charset=utf-8," +
> +  encodeURIComponent("<h1>test filter context menu</h1>");
> +
> +add_task(function* () {
> +
> +  let {tab, toolbox, inspector} = yield openInspectorForURL(TEST_URI);

Remove 'tab' since it is not used.
Attachment #8780970 - Flags: review?(gl)
Comment on attachment 8780970 [details]
Bug 1294937 - The context menu does not appear when right-click on the inspector-searchbox;

https://reviewboard.mozilla.org/r/71484/#review69506
Comment on attachment 8780970 [details]
Bug 1294937 - The context menu does not appear when right-click on the inspector-searchbox;

https://reviewboard.mozilla.org/r/71484/#review69716

::: devtools/client/inspector/test/browser_inspector_search-filter_context-menu.js:15
(Diff revisions 3 - 4)
>  
>  add_task(function* () {
> -
> -  let {tab, toolbox, inspector} = yield openInspectorForURL(TEST_URI);
> +  yield addTab("data:text/html;charset=utf-8," + encodeURIComponent(TEST_URI));
> +  let {toolbox, inspector} = yield openInspector();
>    let {searchBox} = inspector;
> -  yield selectNode("h1", inspector);
> +  yield selectNode(TEST_INPUT, inspector);

I think it will be better to keep this as "h1".
Attachment #8780970 - Flags: review?(gl) → review+
issue addressed, change commit message to ; r=gl

thanks!
Keywords: checkin-needed
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/fx-team/rev/165ca35b1586
The context menu does not appear when right-click on the inspector-searchbox. r=gl
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/165ca35b1586
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 51
Iteration: --- → 51.2 - Aug 29
Priority: P3 → P1
I reproduced this bug using Fx 51.0a1, build ID: 20160812030200, on Windows 10 x64.
I can confirm the bug is fixed, I verified using Fx 51.0a1 build ID: 20160819030226, on Windows 10 x64, Ubuntu 14.04 LTS and Mac OS X 10.10.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.