If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Implement ReadableStream / WritableStream

RESOLVED DUPLICATE of bug 1128959

Status

()

Core
Audio/Video: MediaStreamGraph
RESOLVED DUPLICATE of bug 1128959
a year ago
5 months ago

People

(Reporter: timse201, Unassigned, NeedInfo)

Tracking

(Blocks: 1 bug, {dev-doc-needed})

Trunk
dev-doc-needed
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [needinfo 2016/08/15 to jesup, cpearce, padenot], URL)

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:48.0) Gecko/20100101 Firefox/48.0
Build ID: 20160726073904

Steps to reproduce:

quote: "This specification provides APIs for creating, composing, and consuming streams of data. These streams are designed to map efficiently to low-level I/O primitives, and allow easy composition with built-in backpressure and queuing. On top of streams, the web platform can build higher-level abstractions, such as filesystem or socket APIs, while at the same time users can use the supplied tools to build their own streams which integrate well with those of the web platform."
(Reporter)

Updated

a year ago
Blocks: 568516
OS: Unspecified → All
Hardware: Unspecified → All
(Reporter)

Updated

a year ago
Summary: Implement ReadableStream → Implement ReadableStream / WritableStream
Keywords: dev-doc-needed
@cpearce, @jesup, @pehrsons -- What are your opinions on implementing this?
Component: Audio/Video → Audio/Video: MediaStreamGraph
Flags: needinfo?(rjesup)
Flags: needinfo?(pehrson)
Flags: needinfo?(cpearce)
Whiteboard: [needinfo 2016/08/15 to jesup, cpearce, padenot]

Updated

a year ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1128959
Is it really an MSG thing? It seems like its being implemented in bug 1128959.

We could discuss integration with MediaStreams but that would need some spec work first?
Flags: needinfo?(pehrson)
(In reply to Andreas Pehrson [:pehrsons] (Telenor) from comment #3)
> We could discuss integration with MediaStreams but that would need some spec
> work first?

Correct.  AFAIK only fetch API integrates ReadableStream.  No current spec integrates WritableStream (especially since WritableStream is not stable in the streams spec yet).
(In reply to Maire Reavy [:mreavy] Please needinfo me from comment #1)
> @cpearce, @jesup, @pehrsons -- What are your opinions on implementing this?

Having progressive fetch is desired by several partners who do streaming video.
Flags: needinfo?(cpearce)
I've been wanting to use this for a variety of things, none of them being urgent:
- A VideoWork{let,er} spec
- Overhaul of `AudioContext.decodeAudioData` to be able to partially decode a file
- Extension of `MediaRecorder`

This has nothing to do with the MSG, though, this spec is about non-real-time data streams.
You need to log in before you can comment on or make changes to this bug.