Occasional hangs in the GC

RESOLVED DUPLICATE of bug 1288579

Status

()

RESOLVED DUPLICATE of bug 1288579
2 years ago
2 years ago

People

(Reporter: billm, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Recently I've noticed my content process hanging. It's happened two or three times, maybe once a week. Here's a stack trace on the main thread:

#0  pthread_cond_wait@@GLIBC_2.3.2 ()
    at ../sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007f69fdf0d16f in js::ConditionVariable::wait_for(js::LockGuard<js::Mutex>&, mozilla::BaseTimeDuration<mozilla::TimeDurationValueCalculator> const&)
    () from /home/billm/Downloads/firefox/libxul.so
#2  0x00007f69fdddff07 in js::GCParallelTask::join() ()
   from /home/billm/Downloads/firefox/libxul.so
#3  0x00007f69fe3c1d89 in js::gc::GCRuntime::incrementalCollectSlice(js::SliceBudget&, JS::gcreason::Reason, js::AutoLockForExclusiveAccess&) ()
   from /home/billm/Downloads/firefox/libxul.so
#4  0x00007f69fdd7c6de in js::gc::GCRuntime::gcCycle(bool, js::SliceBudget&, JS::gcreason::Reason) () from /home/billm/Downloads/firefox/libxul.so
#5  0x00007f69fdd7cbf7 in js::gc::GCRuntime::collect(bool, js::SliceBudget, JS::gcreason::Reason) () from /home/billm/Downloads/firefox/libxul.so
#6  0x00007f69fe3c2402 in js::gc::GCRuntime::startGC(JSGCInvocationKind, JS::gcreason::Reason, long) () from /home/billm/Downloads/firefox/libxul.so
#7  0x00007f69fe1667e3 in nsJSContext::GarbageCollectNow(JS::gcreason::Reason, nsJSContext::IsIncremental, nsJSContext::IsShrinking, long) ()
   from /home/billm/Downloads/firefox/libxul.so
#8  0x00007f69fd6c35a9 in nsTimerImpl::Fire() ()
   from /home/billm/Downloads/firefox/libxul.so

All the other JS engine threads that I could see were blocked on condition variables. I guess the next time it happens I can get stacks for all of them.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1288579
You need to log in before you can comment on or make changes to this bug.