Closed Bug 1295029 Opened 4 years ago Closed 2 years ago

Allow Emoji One to be used for all emoji.

Categories

(Core :: Graphics: Text, defect, P3)

32 Branch
defect

Tracking

()

RESOLVED DUPLICATE of bug 1032671

People

(Reporter: caspy77, Unassigned)

References

Details

(Whiteboard: [gfx-noted])

Attachments

(1 file)

Bug 1231701 allows Firefox to insert emoji where the platform's current emoji set is missing them.
I'm seeing this in Dev Edition (50) and it's great.

However, many of the existing emoji in my current OS *stink*.  Additionally, the two emoji sets together are thematically inconsistent.

We should allow users to opt in to letting Firefox provide all emoji.  This will, in some cases, improve a poor emoji set and in general make for a consistently themed emoji experience.
I think this would be easier to consider once we get bug 1032671 finished/landed, so that there's a font pref that's specific to the emoji characters.
Depends on: 1032671
Component: General → Graphics: Text
Product: Firefox → Core
Whiteboard: [gfx-noted]
Caspy7, since bug 1032671 is landed, could you verify this on the latest Nightly?
Flags: needinfo?(caspy77)
Um, bug 1032671 is just a dependency of this but, fixing it does not necessarily fix this bug, it just removes a blocker.
Or am I wrong?

And if so, how does one enable this?

...also I'm probably not the person to test this as I've already installed EmojiOne System-wide so that I don't personally experience my original complaint (many others still do of course).
Flags: needinfo?(caspy77)
(In reply to Caspy7 from comment #3)
> Um, bug 1032671 is just a dependency of this but, fixing it does not
> necessarily fix this bug, it just removes a blocker.
> Or am I wrong?
> 
> And if so, how does one enable this?
> 
> ...also I'm probably not the person to test this as I've already installed
> EmojiOne System-wide so that I don't personally experience my original
> complaint (many others still do of course).

What platform do you use?  I test on Windows 10.
(In reply to Makoto Kato [:m_kato] (slow due to PTO?) from comment #4)
> What platform do you use?  I test on Windows 10.

I'm on Windows 10 as well.
(In reply to Caspy7 from comment #3)
> Um, bug 1032671 is just a dependency of this but, fixing it does not
> necessarily fix this bug, it just removes a blocker.
> Or am I wrong?
> 
> And if so, how does one enable this?

set font.name-list.emoji to any emoji font via about:config
(In reply to Makoto Kato [:m_kato] (slow due to PTO, back at Jan) from comment #6)
> (In reply to Caspy7 from comment #3)
> > Um, bug 1032671 is just a dependency of this but, fixing it does not
> > necessarily fix this bug, it just removes a blocker.
> > Or am I wrong?
> > 
> > And if so, how does one enable this?
> 
> set font.name-list.emoji to any emoji font via about:config

Just tested this on Windows 10 with Firefox Nightly and it works!
Thanks, mark as dup of bug 1032671.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1032671
I don't think this is resolved at all. I just tested on emojipedia, https://emojipedia.org/people/ and on my OS (Windows 7) it picks (B&W) Segoe UI Symbol smileys instead of color emoji (twemoji). It doesn't allow the embedded emoji font (set with font.name-list.emoji) to be used.

If an emoji font is set, it should override any other font that might contain a glyph for the same emoji and be give first priority -- otherwise you're going to keep having these weird mixed emoji.
(In reply to Mark Straver from comment #9)
> If an emoji font is set, it should override any other font that might
> contain a glyph for the same emoji and be give first priority -- otherwise
> you're going to keep having these weird mixed emoji.

This is not how font.name-list.* behaves. I agree this is a useful idea, I've tried to propose similar one in bug 1260637 but it didn't get any traction. Perhaps if you file a new bug and articulate the solution needed, people would love your idea.

BTW the Emojipedia people is very responsive on Twitter. I remember they said they couldn't remove the font-family for some reason. If might be quicker if you ask them to put "Twemoji Mozilla" ahead in their list.
See Also: → 1460445
Thanks Tim,

I filed bug 1460445 for this. I think it's very important if you want the browser to provide a consistent experience to the user.

As for having the font added to the emojipedia pages... although that would solve the immediate issue on that particular site, it wouldn't solve the issue on any other site and you can hardly start asking all sites that use emoji to add specific Mozilla fonts as first entry to their font list whenever emoji are in play because the browser otherwise acts inconsistently.
(Let me move the discussion to bug 1460445)
You need to log in before you can comment on or make changes to this bug.