Closed Bug 1295061 Opened 3 years ago Closed 3 years ago

[WebGL2] Enable conformance tests for Windows 8

Categories

(Core :: Canvas: WebGL, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla51
Tracking Status
firefox51 --- fixed

People

(Reporter: daoshengmu, Assigned: daoshengmu)

Details

Attachments

(1 file)

Remove WEBGL2_SKIP_IF_CONDITION = (os == 'win' && os_version == '6.2')
and rebuild mochitest files.
Depends on: 1290333
After Bug 1290333 land, we can start to enable WebGL 2 in Windows 8 try servers.
Assignee: nobody → dmu
Try looks good when I use fail-if at
test_2_conformance__glsl__constructors__glsl-construct-bvec2.html
test_2_conformance__glsl__constructors__glsl-construct-bvec3.html
test_2_conformance__glsl__constructors__glsl-construct-bvec4.html
test_2_conformance__glsl__constructors__glsl-construct-ivec2.html
test_2_conformance__glsl__constructors__glsl-construct-ivec3.html
test_2_conformance__glsl__constructors__glsl-construct-ivec4.html

https://treeherder.mozilla.org/#/jobs?repo=try&revision=5ecf356567b5
Adding other fail-if for
test_2_conformance__glsl__constructors__glsl-construct-vec-mat-corner-cases.html
test_2_conformance__glsl__constructors__glsl-construct-vec2.html
test_2_conformance__glsl__constructors__glsl-construct-vec3.html
test_2_conformance__glsl__constructors__glsl-construct-vec4.html

I believe this is because try servers use old driver version like our Windows 7 cases. I have confirmed it could be passed after I update NV driver to 2016.7 version in my loaner. 

And I think using fail-if is better that using skip-if. Because I imagine one day we will update our drivers, and we can aware this tests have already can be passed easily.

Try looks good.
https://treeherder.mozilla.org/#/jobs?repo=try&revision=cdd899a1cf97
Comment on attachment 8783375 [details]
Bug 1295061 - Enable WebGL 2 conformance tests for Windows 8;

https://reviewboard.mozilla.org/r/73184/#review70950
Comment on attachment 8783375 [details]
Bug 1295061 - Enable WebGL 2 conformance tests for Windows 8;

https://reviewboard.mozilla.org/r/73186/#review70952

Great!
Attachment #8783375 - Flags: review?(ethlin) → review+
Comment on attachment 8783375 [details]
Bug 1295061 - Enable WebGL 2 conformance tests for Windows 8;

https://reviewboard.mozilla.org/r/73186/#review71562
Attachment #8783375 - Flags: review?(jgilbert) → review+
In this update, I skip generated/test_2_conformance__canvas__drawingbuffer-static-canvas-test.html for needing more time to investigate and remove fail-if in generated/test_2_conformance__canvas__rapid-resizing.html because Win 8 can be pass in that test.
No longer depends on: 1290333
Keywords: checkin-needed
Pushed by archaeopteryx@coole-files.de:
https://hg.mozilla.org/integration/autoland/rev/5a63a118b8b9
Enable WebGL 2 conformance tests for Windows 8; r=ethlin,jgilbert
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/5a63a118b8b9
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla51
You need to log in before you can comment on or make changes to this bug.