browser caches mimetype info? if server changes mimetype browser not aware

RESOLVED DUPLICATE of bug 198072

Status

()

RESOLVED DUPLICATE of bug 198072
17 years ago
16 years ago

People

(Reporter: webform1, Assigned: gordon)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.8) Gecko/20020204
BuildID:    2002020406

Browser does not take note of changes in mimetype as provided by server.  For
example, default apache/Red Hat install does not map xls extension to msexcel
mimetype (vnd.ms-excel, to be specific).  After mapping that extension to xls in
server mime.types and restarting server, Mozilla not aware of new mimetype info.

Resolution: manually delete ALL cache files from Mozilla cache directory.

Using cache clearing from within Mozilla, and/or restarting does not resolve.






Reproducible: Always
Steps to Reproduce:
1. attempt to download file of selected type, note mimetype
2. change mimetype at server, restart
3. attempt download of file, note mimetype

Actual Results:  Mozilla continues to see the file as mimetype from the first
download attempt.

Expected Results:  Mozilla will re-read mimetype info being provided by server
and act accordingly.
Mozilla caches the entire server response (headers, data, etc).  This is in fact
the only reasonable thing to cache.  When we then get the file again, we just
read it from our cache, headers and all.  This is necessary for proper
functioning of the cache in general....
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID

Comment 2

16 years ago
Catching up.  Please reopen bug if there is still a problem.  Marking Verified!
Status: RESOLVED → VERIFIED
QA Contact: benc → jimmylee

Comment 3

16 years ago
REOPEN:

I'd like gordon+tom to look at this before closing. There might be some user
concerns they should hear, plus, we don't know if their cache settings are
correct. Since this is also a downloaded file, it seems to me it should not live
in cache;
Status: VERIFIED → UNCONFIRMED
Component: Networking → Networking: Cache
Resolution: INVALID → ---

Comment 4

16 years ago
-> cache, -> new, based on bz's comments.
Assignee: new-network-bugs → gordon
Status: UNCONFIRMED → NEW
Ever confirmed: true
QA Contact: jimmylee → tever
(Assignee)

Comment 5

16 years ago
I think this is the same issue as bug 198072.  Shift-Reload should load the
updated document without have to clear the entire cache.



*** This bug has been marked as a duplicate of 198072 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.