Closed Bug 1296043 Opened 5 years ago Closed 4 years ago

new tabs should always open to the immediate right of the active tab

Categories

(Firefox :: Tabbed Browser, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1344749

People

(Reporter: dietrich, Unassigned)

Details

Benefits of living daily with all tabs opened immediately to the right by default:

* My tabs have organically entered the holy grail state: All related tabs are in contiguous groups.

* There's no more mystery or anxiety about where a tab will open up or where it went. It's 100% consistent behaviour.

* I no longer need to execute the RSI-inducing pattern of "(keyboard shortcut to move to the next tab) * n, where n is the distance between the active tab and the end of the tab strip". This alone is *amazing*.

* Adding a new tab keeps me in the context of my current activity instead of teleporting me away. I am now in control of whether I want to start a new sphere of work, instead of the browser deciding on its own. Turns out that when I open new tab it's because I'm continuing a task, but don't want to lose the tab I'm currently on.

The only case in which I prefer tab-at-end is when it's from a link opened from an external application.

See also bug 528005, which has comments from people interested in comprehensive tab positioning solution.
(In reply to Dietrich Ayala (:dietrich) from comment #0)
> * I no longer need to execute the RSI-inducing pattern of "(keyboard
> shortcut to move to the next tab) * n, where n is the distance between the
> active tab and the end of the tab strip". This alone is *amazing*.

I mean, ctrl/cmd-9 does this with 1 shortcut... no need for RSI either way.

> * Adding a new tab keeps me in the context of my current activity instead of
> teleporting me away. I am now in control of whether I want to start a new
> sphere of work, instead of the browser deciding on its own. Turns out that
> when I open new tab it's because I'm continuing a task, but don't want to
> lose the tab I'm currently on.

What if it isn't? What if you're starting a new task and now the new tab got inserted between the current tab and the links you opened from that current tab?

Anyway, this is all a UX question and bugzilla is a poor medium for that discussion. Forwarding to shorlander, and maybe we should just talk about this in fx-dev instead.
Flags: needinfo?(shorlander)
I second the request.

* A new tab opened by middle-clicking a link is obviously related to the current task.
* A new tab opened from history is obviously related to the current task.
* A new tab opened from a bookmark or the address bar might or might not be related. There are at least two reasons to assume it is:
  * Tasks are continued much more often than new tasks are started.
  * Placing the new tab near the previous one preserves context. Placing it at the far end destroys context (the user has to look for the previous tab).

This used to be provided by TabMixPlus. We need either an equivalent built-in preference, or a way for extensions to implement this.
There is now (on nightly 61) a hidden pref that's exposed to add-ons to toggle. Fixed in bug 1344749.
Status: NEW → RESOLVED
Closed: 4 years ago
Flags: needinfo?(shorlander)
Resolution: --- → DUPLICATE
Duplicate of bug: 1344749
You need to log in before you can comment on or make changes to this bug.