Closed Bug 1296096 Opened 4 years ago Closed 3 months ago

Wrong favicon shown in awesomebar result

Categories

(Toolkit :: Places, defect, P3)

50 Branch
x86
macOS
defect

Tracking

()

RESOLVED DUPLICATE of bug 1533480

People

(Reporter: rfeeley, Unassigned)

Details

Attachments

(2 files)

Attached image wrong-favicon.png
STR
Open a Google doc
Type partial name of doc in location bar

ER
Google docs favicon is shown in results

AR
Google favicon is shown in results
Not sure whether this belongs in Places or Autocomplete.  Probably Places.  Might need investigation to find out where the problem is.
Component: Location Bar → Places
Product: Firefox → Toolkit
Summary: Google favicon shown for Google doc in open tab → Wrong favicon shown in awesomebar result
it's probably due to redirects, that makes me think fixing this could break other pages.
Priority: -- → P3

I've been experiencing this for a long time - even now on 75.0b11 - is there anything I can do to help debug?

Attached another (redacted) screenshot showing:

  • the correct icon for drive.google.com
  • the wikipedia icon for drive.google.com
  • the microsoft icon for drive.google.com
  • the wikipeida icon for an open tab with drive.google.com
  • the correct icon for drive.google.com
  • the correct icon for onedrive
  • the wikipedia icon again for drive.google.com
  • the microsoft icon again for drive.google.com
  • two correct results on google.com

I don't think yout bug is related to this one, it's more likely bug 1533480. We landed a fix in Firefox 75 that long term should help there, but it may take some time (the expiration happens in small chunks).
It's likely your favicons.sqlite database contains wrong icons for some redirects. the immediate solution would be to remove favicons.sqlite from the profile folder, and let Firefox generate a new one, that would unfortunately lose favicons for all the pages until they are reloaded at least once. The long term solution may involve just waiting. I'm monitoring the solution and we may decide to speed up the process a bit.

Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1533480
You need to log in before you can comment on or make changes to this bug.