If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Unresponsive page in one tab breaks display of other tabs

RESOLVED DUPLICATE of bug 1207306

Status

()

Firefox
Tabbed Browser
RESOLVED DUPLICATE of bug 1207306
a year ago
a year ago

People

(Reporter: sebo, Unassigned)

Tracking

({perf, testcase})

Trunk
x86_64
Windows 7
perf, testcase
Points:
---

Firefox Tracking Flags

(firefox51 affected)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

a year ago
Created attachment 8782284 [details]
Throbber shown instead of website

Having e10s enabled, an unresponsive page in one tab breaks the display of all other tabs.

Steps to reproduce:
1. Create a new Firefox profile
2. Go to https://www.mozilla.org/en-US/
3. Open a new tab and go to https://ello.co/ddailey/post/hwqd8hmolnwx7-vp4zocfq [1]
4. Switch back to the first tab

=> A throbber is shown instead of the website.

I've tested this using 64-bit versions of Nightly 51.0a1 (2016-08-17) and Developer Edition 50.0a2 (2016-08-17) on Windows 7 SP1 64-bit.

(With e10s disabled the website hangs the whole browser.)

Sebastian

[1] Got that link from https://lists.w3.org/Archives/Public/www-svg/2016Aug/0033.html
(Reporter)

Updated

a year ago
Keywords: perf, testcase
(Reporter)

Updated

a year ago
See Also: → bug 1167471
(Reporter)

Comment 1

a year ago
Note that the freeze is caused by an SVG image located at http://cs.sru.edu/~ddailey/svg/modifier3RBlendSnapMode.svg. While the freezing should be fixed in bug 1167471, freezing of a single tab should not have any influence on other tabs' contents.

So I guess that will be solved with bug 1207306, right?

Sebastian
Flags: needinfo?(mconley)

Comment 2

a year ago
I think this is basically just "no e10s-multi yet" in bug form, but I'll let mconley decide and dupe/close.
Component: General → Tabbed Browser
Yeah, in this case, the shared content process between all tabs is likely being bogged down with that SVG parse / render. e10s-multi will likely fix this.

For cases where a website is doing something JS-heavy, we actually have a workaround for that in bug 1279086, where we'll interrupt the JS engine to prioritize painting, but I don't think that'll affect this particular case.
Status: NEW → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(mconley)
Resolution: --- → DUPLICATE
Duplicate of bug: 1207306
You need to log in before you can comment on or make changes to this bug.