Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 1292522
2 years ago
2 years ago

People

(Reporter: adp.saar, Unassigned)

Tracking

48 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/52.0.2743.116 Safari/537.36

Steps to reproduce:

have 2 servers running on the same domain but different ports (10300) and (300).

a page (port 10300) has an iframe with port 300.
both outside page and iframe use document.domain = ".." to align the domains and "reset" the port.
trying to reach the parent document from within the iframe now fails (did not happen in previous versions)


Actual results:

Receive permission denied error from trying to reach parent.document


Expected results:

expected result domains were aligned and javascript functions should not have failed.
(Reporter)

Comment 1

2 years ago
This issue has been reported by a few customers of ours already, only happens in firefox 48.
works in Firefox 47, Chrome 51, IE11, Edge
Can you provide a testcase?

If it's not possible, can you find out what change causes the issue, by mozregression tool?
http://mozilla.github.io/mozregression/
Flags: needinfo?(adp.saar)
(Reporter)

Comment 3

2 years ago
Hi,

I have added the following file:
https://github.com/saard/bugs/blob/master/double.js

run it using:
node double.js

Thanks.
(Reporter)

Updated

2 years ago
Flags: needinfo?(adp.saar)
Thanks you :)

It's apparently a dupe of bug 1292522.
I confirmed the regression from bug 409885's patch, and also the fix on the binary in the try run there.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1292522
You need to log in before you can comment on or make changes to this bug.