Closed Bug 1296374 Opened 5 years ago Closed 5 years ago

Our company user SAP BW/Business Object reports. Version 47.0.1 worked fine, but when I upgraded to 48.0.1, Filter Variable selection screen in SAP BW locks up.

Categories

(Firefox :: Untriaged, defect)

48 Branch
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: thewebjester, Unassigned, NeedInfo)

References

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; Trident/7.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET CLR 1.1.4322; .NET4.0C; .NET4.0E; rv:11.0) like Gecko

Steps to reproduce:

Our company user SAP BW/Business Object reports.  Version 47.0.1 worked fine, but when I upgraded to 48.0.1,  Filter Variable selection screen in SAP BW Web UI locks up. First confirmed with an End user I support...who was already upgraded Firefox to 48.0.1. We tried Clearing all History and disabling all Add-Ons to no Avail.

I Tested On My PC instance of Firefox (which was still on version 47.0.1) and got expected results. I then Upgraded my Firefox version from 47.0.1 to 48.0.1 and now I have the same issue. As soon as I click any of the Variable filter options, I see Scroll bars appear on the page, and a BUSY icon that will not go away until I navigate away from page. 


Actual results:

See above fro description of occurrence. 


Expected results:

A popup window to select related Filter variables should appear. (with no BUSY Icon).

I also tested the same reports in Internet Explorer and do not encounter this issue...and am confident in my troubleshooting abilities to say it is definitely related to that Upgrade. 

I can Downgrade as needed, but auto updates for the general end user masses will cause this to be a Company-wide spread issue for us if not addressed quickly.
since the issue is specific to "SAP BW/Business Object reports", that's not available publicly, it's unlikely to be able to reproduce it.

Can you try mozregression to find out which changeset introduced the issue?
http://mozilla.github.io/mozregression/
Flags: needinfo?(thewebjester)
Hi Rich,

Have you tried to perform a mozregression like Tooru suggested in comment 1? 
Also, can you please test this issue on the latest Firefox release using a new clean Firefox profile and report back the results? (https://goo.gl/PNe90E).

Is there any way to provide us a test case or a page in order to test this issue?
Not permitted to install 3rd party tools onto my Work PC to test as requested, But am 100% certain the issue is due to 48.0.1 Build changes.

to troubleshoot, I uninstalled 48.0.1 and then Installed 47.0.1, and the issue no longer occurs. Let updates occur again, and issue returns. Also tried on a test PC with a much older version of Mozilla installed (42.0.1), were it worked prior to update, then after update to 48.0.1, the issue occurred on that PC as well.

Uninstall/Downgrade back to 47.0.1 also fixed for that PC.

No changes to the SAP Software that would have triggered this, it is 100% due to Mozilla upgrade, and am fairly certain it has something to do with the security changes just released that are affecting nested URLs within pages not being trusted,regardless if those sites were added to Trusted zone in Internet settings.


What I also tried that is weird, is that I had reverted to 47.0.1 (clean 48.0.1 uninstall/47.0.1 reinstall), and the Auto Updates put me back to 48.0.1 again before I can get to HELP > ABOUT to disable, so this time, I disabled the auto updates, then installed 47.0.1 again...this time on top of 48.0.1, and that also fixed the issue...Now  when I check HELP > ABOUT, it says i have version 47.0.1, and that I am up to date...AND the problem is fixed. again, not something we can ask the end users to do themselves, but it says whatever files are being touched from 47.0.1 install on top of 48.0.1 is overwriting the problem files/code causing the issue.

See new version 48.0.2 is causing same issue, no visible fix to issue yet.

Also getting reports from other users of same issue, and current workaround is to use Internet Explorer instead to access our company CRM App instead of Mozilla., as we cannot request end users to attempt uninstall 48.0.1 / install 47.0.1 as a standard fix to the issue.
Rich, is the CRM you're using Dynamics CRM by any chance?  If so, is it a fairly old (2+ years) version?

If so, there's a good chance that you're seeing bug 1299593; see also http://www.crmanswers.net/2014/10/lookup-errors-with-google-chrome-38.html for a clear description of the issue.

I understand that you can't use mozregression due to policy, but can you use a Firefox nightly that you download yourself (similar to downloading Firefox 47, but a nightly build). If so, we can at least test whether the commit range that includes Array.prototype.values matches the commit range when your CRM stopped working...
See Also: → 1299593
I have followed the bug 1299593 that Boris provided in comment 4.

Rich, can you please try to reproduce the issue on this Aurora build and report back the results? https://queue.taskcluster.net/v1/task/BCKeWSltT4Ch6sGOr4x61Q/runs/0/artifacts/public%2Fbuild%2Ffirefox-50.0a2.en-US.win64.zip
This build was provided in bug 1299593 comment 26 with a fix for that bug. If the issue is not reproducible on this build, it means that you encountered the same problem and the bugs are related.

You can download the build, extract the file and run firefox.exe in order to test it.
Flags: needinfo?(thewebjester)
Flags: needinfo?(thewebjester)
Hi All,

I can confirm that release 49.0 does not have this issue. I Upgraded from problem version 48.0.(1&2) to 49.0 and now that issue is no longer occurring. BW Report Filter prompts appear as expected now.

Thanks for taking the time to troubleshoot, but appears root cause was discovered in other reported issues where version 49.0 corrected it for my issue as well. 

Regards
Rich, thank you for getting back on this.  Sounds like this is not the same as bug 1299593, then, since that's not fixed in 49...

It would have been nice to figure out what exactly was going on here, but oh, well.
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Resolution: --- → WORKSFORME
 P.S. to Boris... related to your question:  Rich, is the CRM you're using Dynamics CRM by any chance?  Answer is no. We use SAP CRM 7.03 (which is the latest build).
;-)

Regards
You need to log in before you can comment on or make changes to this bug.