If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Allow tasks to signal that they should be retried within TaskCluster

RESOLVED DUPLICATE of bug 1298129

Status

Taskcluster
Worker
RESOLVED DUPLICATE of bug 1298129
a year ago
7 months ago

People

(Reporter: garndt, Unassigned)

Tracking

(Blocks: 1 bug)

Details

(Reporter)

Description

a year ago
There are occasions where it can be detected within a task that given a change, the task might succeed if it were rerun again.  Instead of reusing the same environment to rerun the command, the task should be able to signal to the worker to resolve the task in such a way that the platform will retry that task.

We have done this in the past with a special exception reason in the queue to have it trigger another run.

Workers should implement something (such as a socket) that is available to the task environment that when written to will cause the worker to resolve the task as an exception with a reason that will cause the rerun by the queue.
(Reporter)

Updated

a year ago
Blocks: 1157948
Dupe of bug 1298129? Can we use that to have those tests retry?
(Reporter)

Comment 2

a year ago
Thanks for pointing that out, definitely a dupe.  gbrown is aware of this work and has a patch to add retrying problematic tests.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1298129
Blocks: 1346574
You need to log in before you can comment on or make changes to this bug.