Crash in IPCError-content | (msgtype=0x2000C,name=???) Route error: message sent to unknown actor ID

RESOLVED FIXED

Status

()

Core
Panning and Zooming
P5
critical
RESOLVED FIXED
2 years ago
a year ago

People

(Reporter: mccr8, Unassigned)

Tracking

({crash, regression})

50 Branch
Unspecified
Mac OS X
crash, regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox48 unaffected, firefox49 unaffected, firefox50 wontfix, firefox51 fixed)

Details

(Whiteboard: [gfx-noted], crash signature)

(Reporter)

Description

2 years ago
This bug was filed from the Socorro interface and is 
report bp-06a12d4b-004d-4c7f-a0ff-d6b232160818.
=============================================================

I'm not sure what is going on here, but there's no but on file yet that I can see. This is not super common (I see about 120 crashes in the last week, on Aurora and Nightly only), but oddly almost all of the crashes are on OSX.

Updated

2 years ago
Component: IPC → DOM: Content Processes
Crash volume for signature 'IPCError-content | (msgtype=0x2000C,name=???) Route error: message sent to unknown actor ID':
 - nightly (version 51): 75 crashes from 2016-08-01.
 - aurora  (version 50): 277 crashes from 2016-08-01.
 - beta    (version 49): 0 crashes from 2016-08-02.
 - release (version 48): 0 crashes from 2016-07-25.
 - esr     (version 45): 0 crashes from 2016-05-02.

Crash volume on the last weeks (Week N is from 08-22 to 08-28):
            W. N-1  W. N-2  W. N-3
 - nightly      21      28      15
 - aurora      106      86      17
 - beta          0       0       0
 - release       0       0       0
 - esr           0       0       0

Affected platforms: Windows, Mac OS X, Linux

Crash rank on the last 7 days:
             Browser Content     Plugin
 - nightly           #29
 - aurora            #9
 - beta
 - release
 - esr
status-firefox50: --- → affected
On 50.0a2 the message type should be Msg_NotifyAPZStateChange__ID. Since then the PAPZ protocol has been changed by bug 1289650 so this signature does not show on Nightly after build 20160825030226
status-firefox51: affected → unaffected
Maybe the chiled Send__delete__ and the parent SendNotifyAPZStateChange at the same time and the message crossed? Can this happen?
Component: DOM: Content Processes → Graphics
Flags: needinfo?(bugmail)
I guess it's possible, although I thought I fixed those problems by adding the two-step destruction in bug 1255823.

I looked up the crash-stats for this one and the first buildid it showed up on was 20160722030235 which gives us a regression range of [1] (one day) or [2] (two days). That range includes bug 1281575 which seems like the most likely candidate to me, as it touched the APZ IPDL code.

It could very well be that this crash still exists in current Nightly but under a different signature.

[1] https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=d224fc999cb6accb208af0a105f14433375e2e77&tochange=e0bc88708ffed39aaab1fbc0ac461d93561195de
[2] https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=ed8e23b5e0c7b739e61173bb180cf3410a306679&tochange=e0bc88708ffed39aaab1fbc0ac461d93561195de
Blocks: 1281575
Flags: needinfo?(bugmail)
status-firefox48: --- → unaffected
status-firefox49: --- → unaffected
Component: Graphics → Panning and Zooming
Keywords: regression
Whiteboard: [gfx-noted]
Version: Trunk → 50 Branch
As far as I can tell there's no IPCError-content signature that suddenly appeared on aug 25 or aug 26 (which this one might have morphed into). Based on that I feel like the crash may have been fixed by bug 1289650.
Depends on: 1289650
P5 for now since there's nothing really actionable short of uplifting bug 1289650 and that I don't to do because it's a large risky changeset. If nothing else turns up before the next merge we can close this bug as WFM and wontfix it for firefox-50.
Priority: -- → P5
Whiteboard: [gfx-noted] → [gfx-noted][closeme 2016-09-13]
No change here. It appears to have been fixed by bug 1289650 which I don't want to uplift. I propose we just wontfix this for 50, although if we want to fix we could try backing out bug 1281575 from 50 since it's just prep work for later changes. I don't know how involved that backout would be though, there might have been other stuff that landed on top of it.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox50: affected → wontfix
Resolution: --- → FIXED
Whiteboard: [gfx-noted][closeme 2016-09-13] → [gfx-noted]
status-firefox51: unaffected → fixed
This unfortunately became a pretty high volume crash on 50 :(
It's ~2000 crashes per week, which is pretty high for a Mac-only crash.
You need to log in before you can comment on or make changes to this bug.