window.close closes imediatelly whole browser with all opened tabs

VERIFIED DUPLICATE of bug 103452

Status

Rhino
Core
VERIFIED DUPLICATE of bug 103452
16 years ago
14 years ago

People

(Reporter: Lubor Kolar, Assigned: Norris Boyd)

Tracking

other
1.5R4
x86
Windows XP

Details

(URL)

(Reporter)

Description

16 years ago
This is URL of internet bankning application. When I login and later try to
logoff, Javascript code will ty to close browser window. Mozilla (BUILD ID
2002020406) will close its main window WITHOUT CONFIRMATION (Exploder tells me
"This page is trying to close window. Do you want to close it?" and it closed
whole window although I had about 5 other tabs opened. 
IMHO this should be fixed because window.close should be related to tab, not to
whole Mozilla window. I would also appreciate if browser will ask me first
(maybe as checkbox setting (confirm JS close window).

Comment 1

16 years ago

*** This bug has been marked as a duplicate of 103452 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 2

16 years ago
Marking Verified Duplicate - 
Status: RESOLVED → VERIFIED

Comment 3

14 years ago
Targeting as resolved against 1.5R4
Target Milestone: --- → 1.5R4
You need to log in before you can comment on or make changes to this bug.