Fix DirectX shutdown order

RESOLVED FIXED in Firefox 50

Status

()

RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: dvander, Assigned: dvander)

Tracking

(Blocks: 1 bug)

unspecified
mozilla51
Points:
---

Firefox Tracking Flags

(firefox49+ wontfix, firefox50 fixed, firefox51 fixed)

Details

Attachments

(1 attachment)

I'm still not sure exactly how I got this to manifest, or why it doesn't manifest normally, but the way we shutdown DirectX is backwards, and was crashing with the GPU process enabled.

Currently it's:
 * Release D3D11
 * Release D2D
 * Release reference draw target

It should be:
 * Release reference draw target
 * Release D2D
 * Release D3D11
Created attachment 8783063 [details] [diff] [review]
patch
Attachment #8783063 - Flags: review?(matt.woodrow)
Attachment #8783063 - Flags: review?(matt.woodrow) → review+

Comment 2

2 years ago
Pushed by danderson@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/7e25ef116964
Fix DirectX shutdown ordering issues. (bug 1296749, r=mattwoodrow)

Comment 3

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/7e25ef116964
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
status-firefox51: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla51
Comment on attachment 8783063 [details] [diff] [review]
patch

Approval Request Comment
This should have a positive impact on reducing crashes in (at least a percentage of) bug 1292311 and  bug 1285333.  The patch has been on 51 since August, so the risk of regressions is very low.
Attachment #8783063 - Flags: approval-mozilla-beta?

Updated

2 years ago
status-firefox50: --- → affected

Comment 5

2 years ago
Comment on attachment 8783063 [details] [diff] [review]
patch

Fix has been on Nightly for a few weeks, should help improve stability, Beta50+
Attachment #8783063 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Comment 6

2 years ago
bugherderuplift
https://hg.mozilla.org/releases/mozilla-beta/rev/9b8bac3cd9eb
status-firefox50: affected → fixed
From the bugs mentioned as affected, sounds like 49 is also affected here too. If this fixes the crash in bug 1292311 we could consider it for 49. 

Andrei, could your team help verify the crash fix on beta 50 once we have more data?
status-firefox49: --- → affected
tracking-firefox49: --- → +
Flags: needinfo?(andrei.vaida)
I tried to reproduce the crashes mentioned by Milan, in bug 1292311 and bug 1285333 with 49 on Windows 7 x86, but unfortunately, I didn't managed. 

David, is there a way I can manually verify this fixes? I am missing something?
When I reproduced this crash, it was on a separate branch and I might have had the debug DirectX SDK installed. So I'm guessing it's not that easy to reproduce.
Thank you, David for your reply. I will remove Andrei's ni? since this issue is a bit complicated for manual verification.
Flags: needinfo?(andrei.vaida)
At this point I think we should stick with waiting for this fix to come along in 50.  Wontfix for 49.
status-firefox49: affected → wontfix
You need to log in before you can comment on or make changes to this bug.