Firefox does not seem be compliant with the WebRTC spec about iceCandidatePoolSize

RESOLVED DUPLICATE of bug 1291894

Status

()

defect
RESOLVED DUPLICATE of bug 1291894
3 years ago
3 years ago

People

(Reporter: guillaume.leclerc.work, Unassigned)

Tracking

48 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:48.0) Gecko/20100101 Firefox/48.0
Build ID: 20160806094113

Steps to reproduce:

let conf = { iceServers:[{urls: 'stun:stun2.l.google.com:19302'}], iceCandidatePoolSize: 30};
const cxn = new RTCPeerConnection(conf);
console.log(cxn.iceGatheringState)


Actual results:

I get "new"


Expected results:

According to the spec I should get "gathering"

From section 4.3.1 Operation We can read: 

When the ICE Agent's ICE candidate pool size is set to a nonzero value and the RTCPeerConnection's ICE gathering state is new, the User Agent MUST start gathering ICE addresses and update the ICE gathering state to gathering.

It seems my use case satisfy all the preconditions and still I get "new" as a state instead of "gathering"
Component: Untriaged → WebRTC
Product: Firefox → Core

Comment 1

3 years ago
I encountered the same problem.
Thanks for the report. We do already have an open ticket for implementing the missing functionality in bug 1291894.
Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1291894
You need to log in before you can comment on or make changes to this bug.