Closed Bug 1297083 Opened 3 years ago Closed 3 years ago

Distorted/slowed-down audio with getUserMedia simultaneously in two tabs

Categories

(Core :: Audio/Video: MediaStreamGraph, defect, P1)

48 Branch
defect

Tracking

()

VERIFIED FIXED
mozilla51
Tracking Status
firefox48 --- unaffected
firefox49 + verified
firefox50 --- verified
firefox51 --- verified

People

(Reporter: pehrsons, Assigned: jesup)

References

Details

(Keywords: regression)

Attachments

(1 file)

Works as expected in 48 but results in the below in 49 onwards.

Steps to reproduce:
3. Open https://mozilla.github.io/webrtc-landing/gum_test.html, click "Audio"
2. Notice that you hear yourself when you speak.
3. Repeat step 1.
4. Speak.

Expected:
Still hearing yourself clear and crisp and with a short delay

Actual:
Audio is playing out slower than usual and distorted
There was an error in the step numbering, I don't have the copy/paste-fu necessary it seems. Here corrected:

Steps to reproduce:
1. Open https://mozilla.github.io/webrtc-landing/gum_test.html, click "Audio"
2. Notice that you hear yourself when you speak.
3. Repeat step 1.
4. Speak.
[Tracking Requested - why for this release]:

Capturing your microphone in two tabs simultaneously is broken.
Rank: 15
Priority: -- → P1
Assignee: nobody → rjesup
Status: NEW → ASSIGNED
Comment on attachment 8783566 [details] [diff] [review]
Don't insert audio for GetUserMedia N times if opened N times

Review of attachment 8783566 [details] [diff] [review]:
-----------------------------------------------------------------

Confirmed working for me.
Attachment #8783566 - Flags: review?(pehrson) → review+
OS: Mac OS X → All
Hardware: Unspecified → All
Pushed by rjesup@wgate.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/d0d255721431
Don't insert audio for GetUserMedia N times if opened N times r=pehrsons
Blocks: 1271585
Rank: 15 → 10
Comment on attachment 8783566 [details] [diff] [review]
Don't insert audio for GetUserMedia N times if opened N times

Approval Request Comment
[Feature/regressing bug #]: bug 1271585

[User impact if declined]: Capturing audio in two tabs will make it unusable

[Describe test coverage new/current, TreeHerder]: We don't test this case.  A test could be written (doesn't have to use two tabs).  Testing for this problem might be tough and timing-dependent, and thus problematic in automation.  (Audio gets stretched and distorted, but there's no frequency change you can key off). If we can get audio quality tests comparing inputs and outputs that would do it (but again be timing/perf-sensitive).

[Risks and why]: No risk.  Removes extraneous loop over sources when inserting.

[String/UUID change made/needed]: none
Attachment #8783566 - Flags: approval-mozilla-beta?
Attachment #8783566 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/d0d255721431
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla51
Comment on attachment 8783566 [details] [diff] [review]
Don't insert audio for GetUserMedia N times if opened N times

Review of attachment 8783566 [details] [diff] [review]:
-----------------------------------------------------------------

This patch fixes a capturing microphone regression. Take it in 50 aurora and 49 beta. Should be in 49 beta 7.
Attachment #8783566 - Flags: approval-mozilla-beta?
Attachment #8783566 - Flags: approval-mozilla-beta+
Attachment #8783566 - Flags: approval-mozilla-aurora?
Attachment #8783566 - Flags: approval-mozilla-aurora+
Flags: qe-verify+
Duplicate of this bug: 1295561
Track 49+ as this is a regression for capturing microphone in multiple tabs.
Confirming that the issue no longer reproduces on Mac OS X 10.9.5, Ubuntu 12.04 x86 and Windows 10 x64 using:
*latest 51.0a1 Nightly, build ID 20160831030224
*latest 50.0a2 Aurora, build ID 20160901004001
*Fx 49.0b8, build ID 20160829102229
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.