stylo: Skip initial style of explicit children for XBL-bound nodes

RESOLVED DUPLICATE of bug 1294572

Status

()

Core
CSS Parsing and Computation
P3
normal
RESOLVED DUPLICATE of bug 1294572
a year ago
11 months ago

People

(Reporter: Bobby Holley (parental leave - send mail for anything urgent), Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

When doing the initial style traversal of the document, styling explicit children of XBL-bound nodes can be wasted work if the binding has anonymous content and the explicit children get rebound to insertion points.

We should consider just culling eager traversal if we end up with a non-trivial mozBinding when cascading the parent.
Priority: -- → P3
I filed this twice.
Status: NEW → RESOLVED
Last Resolved: 11 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1294572
You need to log in before you can comment on or make changes to this bug.