Closed Bug 1297288 Opened 3 years ago Closed 3 years ago

Ctrl+[, Ctrl+] in developer tools trigger page back/forward

Categories

(DevTools :: General, defect, P2)

defect

Tracking

(firefox51 fixed)

RESOLVED FIXED
Firefox 51
Tracking Status
firefox51 --- fixed

People

(Reporter: darktrojan, Assigned: ochameau)

References

Details

Attachments

(1 file)

I suspect this is caused by the same thing as bug 1292081, given the similarities.

STR:
In a browser window with some browsing history, open the devtools and press Ctrl+[. The browser loads the previous page as well as the devtools switching to the previous tool. Pressing Ctrl+] loads the next page.
Blocks: 1268450
See Also: → 1292081
:ochameau, can you triage this shortcuts issue?
Flags: needinfo?(poirot.alex)
I don't know about the priority to give, but I'll look into it.
Assignee: nobody → poirot.alex
Status: NEW → ASSIGNED
Flags: needinfo?(poirot.alex)
Priority: -- → P2
Attached patch patch v1Splinter Review
I looked at all usages of shorcuts.on in devtools/client/ and it seems to be the only one left that are missing some preventDefault call.
Attachment #8784006 - Flags: review?(jryans)
Comment on attachment 8784006 [details] [diff] [review]
patch v1

Review of attachment 8784006 [details] [diff] [review]:
-----------------------------------------------------------------

Great, appears to work well here!
Attachment #8784006 - Flags: review?(jryans) → review+
https://hg.mozilla.org/integration/fx-team/rev/dd07b7887914bf4a8b20301109f5189473bb3aaa
Bug 1297288 - Prevent all toolbox key shortcuts from triggering Firefox equivalents. r=jryans
https://hg.mozilla.org/mozilla-central/rev/dd07b7887914
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 51
I've managed this issue on this bug in Nightly 50.0a1 (2016-08-22) ; (Build ID: 20160822064441) 
from Ubuntu (16.04 Bit) by following comment 0's STR.

This Bug is now verified as fixed on Latest Firefox Aurora 51.0a2 (2016-09-21) (64-bit)

Build ID: 20160921004005
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:51.0) Gecko/20100101 Firefox/51.0
OS: Linux 4.4.0-36-generic ; Ubuntu 16.04.1 (64 Bit)
QA Whiteboard: [bugday-20160921]
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.