Port Bug 1294650 Block Websense Endpoint by providing a dummy DLL

RESOLVED FIXED

Status

RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: frg, Assigned: frg)

Tracking

(Depends on: 1 bug, Blocks: 1 bug)

unspecified
All
Windows
Dependency tree / graph

SeaMonkey Tracking Flags

(seamonkey2.44 wontfix, seamonkey2.45 fixed, seamonkey2.46 fixed, seamonkey2.47 fixed, seamonkey2.48 fixed)

Details

Attachments

(2 attachments)

(Assignee)

Description

2 years ago
Bug 1294650 might affect Seamonkey too so copy the shim 'qipcap' dll also into the Seamonkey folder during installation.
(Assignee)

Comment 1

2 years ago
Created attachment 8783958 [details] [diff] [review]
1297379-websense.patch
Attachment #8783958 - Flags: review?(philip.chee)

Comment 2

2 years ago
Comment on attachment 8783958 [details] [diff] [review]
1297379-websense.patch

r=me a=me
Attachment #8783958 - Flags: review?(philip.chee) → review+
(Assignee)

Comment 4

2 years ago
Leaving open for branches. I think the original bug will get pushed to all fo them.
status-seamonkey2.48: affected → fixed
Whiteboard: [leave open for branches]
(Assignee)

Comment 5

2 years ago
Comment on attachment 8783958 [details] [diff] [review]
1297379-websense.patch

[Approval Request Comment]
Regression caused by (bug #): 
User impact if declined: Seamonkey might crash if Websense is installed.
Testing completed (on m-c, etc.): c-c
Risk to taking this patch (and alternatives if risky): none. Its just a dummy dll.
String changes made by this patch: none
Attachment #8783958 - Flags: approval-comm-beta?
Attachment #8783958 - Flags: approval-comm-aurora?

Updated

2 years ago
Attachment #8783958 - Flags: approval-comm-beta?
Attachment #8783958 - Flags: approval-comm-beta+
Attachment #8783958 - Flags: approval-comm-aurora?
Attachment #8783958 - Flags: approval-comm-aurora+
(Assignee)

Comment 6

2 years ago
Comment on attachment 8783958 [details] [diff] [review]
1297379-websense.patch

[Approval Request Comment]
Has now been pushed to c-r also. See comment 5 for information.
Attachment #8783958 - Flags: approval-comm-release?

Comment 7

2 years ago
Comment on attachment 8783958 [details] [diff] [review]
1297379-websense.patch

a=me for c-r
Attachment #8783958 - Flags: approval-comm-release? → approval-comm-release+
Depends on: 1297534
(Assignee)

Comment 8

2 years ago
https://hg.mozilla.org/releases/comm-aurora/rev/559856ab8275
https://hg.mozilla.org/releases/comm-beta/rev/9dcfba4592a9
https://hg.mozilla.org/releases/comm-release/rev/75e7d671fe05

not closing because original bug has been reopened for further investigation.
status-seamonkey2.45: affected → fixed
status-seamonkey2.46: affected → fixed
status-seamonkey2.47: affected → fixed
Whiteboard: [leave open for branches] → [leave open]
(Assignee)

Updated

2 years ago
Keywords: leave-open
Whiteboard: [leave open]
(Assignee)

Comment 9

2 years ago
Created attachment 8787743 [details] [diff] [review]
1297379-websense-backout.patch

[Approval Request Comment]
Regression caused by (bug #): 1294650 and 1298157
User impact if declined: Windows build fails
Testing completed (on m-c, etc.): c-c
Risk to taking this patch (and alternatives if risky): none
String changes made by this patch: none.
Attachment #8787743 - Flags: review?(philip.chee)
Attachment #8787743 - Flags: review?(iann_bugzilla)
Attachment #8787743 - Flags: approval-comm-release?
Attachment #8787743 - Flags: approval-comm-beta?
Attachment #8787743 - Flags: approval-comm-aurora?

Comment 10

2 years ago
Comment on attachment 8787743 [details] [diff] [review]
1297379-websense-backout.patch

a/r=me
Attachment #8787743 - Flags: review?(iann_bugzilla)
Attachment #8787743 - Flags: review+
Attachment #8787743 - Flags: approval-comm-release?
Attachment #8787743 - Flags: approval-comm-release+
Attachment #8787743 - Flags: approval-comm-beta?
Attachment #8787743 - Flags: approval-comm-beta+
Attachment #8787743 - Flags: approval-comm-aurora?
Attachment #8787743 - Flags: approval-comm-aurora+
(Assignee)

Updated

2 years ago
Attachment #8787743 - Flags: review?(philip.chee)
(Assignee)

Comment 12

2 years ago
I think we can close the bug for now even with bug 1294650 still open.
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Depends on: 1304434

Updated

2 years ago
Blocks: 1305847

Updated

2 years ago
Keywords: leave-open
You need to log in before you can comment on or make changes to this bug.