Unity won't let reveal Firefox menu

RESOLVED DUPLICATE of bug 619899

Status

()

Firefox
Menus
--
blocker
RESOLVED DUPLICATE of bug 619899
a year ago
9 months ago

People

(Reporter: rail, Unassigned)

Tracking

(Depends on: 1 bug, Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

a year ago
Ubuntu uses patched Firefox builds with global menu enabled (requires a special patch). If you try to use an official Firefox build, and try to reveal the menu by pressing Alt, Unity intercepts it and brings up it's own menu search dialog. I couldn't find a way to reveal the menu easily.

It would be great to find a way to fix this issue, because we plan to publish Firefox snap images to Ubuntu Store.
(Reporter)

Updated

a year ago
Summary: Unity wont' let reveal Firefox menu → Unity won't let reveal Firefox menu
Severity: normal → blocker
The patch is here:
http://bazaar.launchpad.net/~mozillateam/firefox/firefox-trunk.head/view/head:/debian/patches/unity-menubar.patch

Comment 2

11 months ago
Mike, could you join in this review?
Flags: needinfo?(mkaply)
Comment hidden (mozreview-request)

Comment 4

11 months ago
I've turned this into a regular Mozilla patch and set it up for review by karlt.

My hope is we can just take this as a regular Firefox patch.

It is a pretty substantial patch, though, so it might take a little time.

Updated

11 months ago
Flags: needinfo?(mkaply)

Comment 5

10 months ago
Created attachment 8823856 [details] [diff] [review]
Add support for Unity menu

The previously attached patch wasn't complete (it seems to miss all of the additional files). I've attached a full version of the patch, which includes all of the new files.

This is a slightly updated and cleaned up version of the patch we've been shipping in Ubuntu for a few years. I'm not sure who can review it, and it's a huge patch too :/ (sorry)
Attachment #8809956 - Attachment is obsolete: true

Comment 6

10 months ago
Created attachment 8823862 [details] [diff] [review]
Add support for Unity menu

Errr, a second attempt with the correct version of the patch this time.
Attachment #8823856 - Attachment is obsolete: true

Comment 7

10 months ago
Comment on attachment 8823862 [details] [diff] [review]
Add support for Unity menu

This is a pretty substantial patch, but a lot of it just seems to be adding in missing menubar widget code for GTK...
Attachment #8823862 - Flags: review?(karlt)

Updated

10 months ago
Depends on: 619899

Comment 8

10 months ago
Comment on attachment 8823862 [details] [diff] [review]
Add support for Unity menu

I'm not available to review this, sorry.

I'm happy for someone else to review, if they can ensure that this is
equivalent to a no-op in other environments and are willing to continue to
maintain this code.  See bug 619899 comment 57 for maintenance
responsibilities.

This should be reviewed in bug 619899 because there is already discussion
there and fixing bug 619899 is not necessarily the only way to address this
bug.

I had a number of questions in earlier comments in bug 619899, which would be
a good place to start.
Attachment #8823862 - Flags: review?(karlt) → review?(mozilla)

Comment 9

10 months ago
Ah, it's been so long since I looked at this that I'd forgotten I'd submitted it for a review in another bug.

Comment 10

10 months ago
chris:

Is the patch in the other bug the same?

Should we dupe this bug to that one?

Any chance Ubuntu is willing to commit to maintaining this code?

Comment 11

10 months ago
(In reply to Mike Kaply [:mkaply] from comment #10)
> chris:
> 
> Is the patch in the other bug the same?
> 
> Should we dupe this bug to that one?
> 
> Any chance Ubuntu is willing to commit to maintaining this code?

The patch in bug 619899 is an out of date version of the one in this bug. It's probably fine to duplicate the bugs, and I'll address the points from Karl in bug 619899 comment 56 on Monday.

I don't know who will maintain this code. I'm hesitant to commit to it because I'm quite busy with another project, and I've over-committed to stuff in the past that I've just ended up neglecting. That said, it hasn't been  that difficult for me to maintain until now. I'm hoping that somebody on the Ubuntu Desktop team will be able to commit to maintaining it in the future though.

Updated

9 months ago
Status: NEW → RESOLVED
Last Resolved: 9 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 619899

Updated

9 months ago
Attachment #8823862 - Flags: review?(mozilla)
You need to log in before you can comment on or make changes to this bug.