Closed Bug 1297627 Opened 6 years ago Closed 6 years ago

[One-off searches] Consider making one-offs grayed out when web search is turned off in Awesomebar

Categories

(Firefox :: Search, defect)

51 Branch
defect
Not set
normal

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox48 --- unaffected
firefox49 --- unaffected
firefox50 --- unaffected
firefox51 --- affected

People

(Reporter: cirdeiliviu, Unassigned)

References

Details

[Affected versions]:
Nightly 51 Build ID 	20160823072522
 
[Steps to reproduce]:
1. Open Firefox with a new profile.
2. Go to about:config and set the preference "keyword.enabled" to false (This turns off web search from Awesome bar  - according to https://support.mozilla.org/en-US/kb/search-web-address-bar).
3. In a new tab type something in the Awesomebar.
4. Click on a one-off searches engine to perform a search.

[Expected result]:
3. One-offs search engines should be grayed out. This will be less confusing for users.
 
[Actual result]:
3. One offs searches engines are not grayed out. This is confusing, because users could try to search with one-offs because they seem active.
4. If user clicks on a one-off searches engine the web search is not performed (as expected).
keyword.enabled is very different from the one-off functionality, it only disallows searching when typing something and pressing enter, and that should continue to happen for now. The support page seems to be badly worded. It's not a search-in-awesomebar-on-off toggle.
Regardless that pref it should still be possible to trigger a search using a one-off button with either the mouse or the keyboard.

At a maximum, it could be confusing if we'd "select" the default engine in the list, but we don't.
Moreover that option is for a very specific category of users that are likely to figure out there's a difference between the 2 behaviors (one happens "transparently" on Enter, the other one must be triggered by selecting the button).

So, imo, this is a wontfix for the above reasons.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.