[OSX 10.12] Safe Browsing Phising warning is not displayed

RESOLVED INVALID

Status

()

Toolkit
Safe Browsing
P1
normal
RESOLVED INVALID
a year ago
a year ago

People

(Reporter: petruta, Unassigned)

Tracking

49 Branch
All
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

a year ago
[Notes]:
- Found while testing Safe Browsing for the validation of Firefox 49.0b6 build 
- This was not reproducible with Firefox 49 beta 6 under Win 10 32-bit and Ubuntu 13.10 32-bit.

[Affected versions]:
- Firefox 49 beta 6

[Affected platforms]:
- Mac OS X 10.12 beta

[Steps to reproduce]:
1. Launch Firefox with a new profile.
2. Access the Safe Browsing test page: http://testsafebrowsing.appspot.com/
3. Allow browser to remain open for a minimum of 14 hours before proceeding further.
4. Under the section titled "Webpage Warnings", open all the sample pages listed at 1, 2, and 3.

[Expected result]:
- The correct error pages are displayed for all three of them.

[Actual result]:
- The error pages are not displayed. Regular webpage is opened containing "Phishing Page Example." text

[Additional notes]:
- Since this requires the browser to be open for a minimum of 14 hours, I will check other versions or regressions if required.
(In reply to Petruta Rasa [QA] [:petruta] from comment #0)
> [Notes]:
> - Found while testing Safe Browsing for the validation of Firefox 49.0b6
> build 
> - This was not reproducible with Firefox 49 beta 6 under Win 10 32-bit and
> Ubuntu 13.10 32-bit.

If I understand correctly, the test was run on Linux and Windows and passed, but it failed on Mac?

If you could let the affected Mac browser open for another 10-12 hours, I would be curious to see if the problem goes away. I suspect it could be a temporary network error.
Flags: needinfo?(petruta.rasa)
Priority: -- → P1
(Reporter)

Comment 2

a year ago
(In reply to François Marier [:francois] from comment #1)
> If I understand correctly, the test was run on Linux and Windows and passed,
> but it failed on Mac?

That's correct. 

> If you could let the affected Mac browser open for another 10-12 hours, I
> would be curious to see if the problem goes away. I suspect it could be a
> temporary network error.

The unwanted software warning was indeed shown after a few more hours. 
Now, the malware warning is displayed too (after about 22 hours since the test started).

The phishing warning is still not shown, I'll check again in a few hours (and tomorrow morning if that's still the case).
Flags: needinfo?(petruta.rasa)
(Reporter)

Comment 3

a year ago
After 48 hours since the browser was started, the phishing error page is still not shown. Updating the summary.
http://testsafebrowsing.appspot.com/s/phishing.html
Summary: [OSX 10.12] Safe Browsing warning pages are not displayed → [OSX 10.12] Safe Browsing Phising warning is not displayed
It is working for me on Mac with Fx 49b6. The only difference I see between my config and yours is that I'm on Mac OSX 10.10.5 and you are on 10.12 beta. 

I wouldn't jump to conclusions on this, but can you try this on other versions of Mac OSX?
Flags: needinfo?(petruta.rasa)
(Reporter)

Comment 5

a year ago
I encountered the same issue on OS X 10.9.5 and 10.11 (let the pc's on for the week-end just to be sure). In both cases, it took longer than 14 hours for the malware and unwanted software warning to appear. The phishing warning is not displayed.

We will run the test again from another network to see if the results are different.
Flags: needinfo?(petruta.rasa)
(In reply to Petruta Rasa [QA] [:petruta] from comment #0)
> [Steps to reproduce]:
> 1. Launch Firefox with a new profile.
> 2. Access the Safe Browsing test page: http://testsafebrowsing.appspot.com/
> 3. Allow browser to remain open for a minimum of 14 hours before proceeding
> further.

Hi Petruta,

"Waiting for 14 hours" - is this part of your existing test cases/plans?
If so, is this bug a regression?
Can you reproduce this bug using older Firefox release, say Firefox 48?
(Reporter)

Comment 7

a year ago
Yes, Ethan, a maximum of 14 hours after the browser was started with a clean profile is needed in order for all the lists to download in background.

We ran the test again on OS X 10.12, in a different network, and this time the test passed.

We are assuming that our network is the culprit so I'm marking this as invalid for now.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → INVALID
(Reporter)

Updated

a year ago
status-firefox49: affected → ---
You need to log in before you can comment on or make changes to this bug.