If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[non-e10s] Tabulation inserted in text input if keydown event is listened for keyCode 9 with alert() in listener

RESOLVED FIXED

Status

()

Core
Widget: Win32
P2
normal
RESOLVED FIXED
a year ago
a year ago

People

(Reporter: vincent, Unassigned)

Tracking

({reproducible})

48 Branch
x86_64
Windows 7
reproducible
Points:
---

Firefox Tracking Flags

(e10s-)

Details

(Whiteboard: tpi:+)

Attachments

(1 attachment, 1 obsolete attachment)

809 bytes, text/html
Details
(Reporter)

Description

a year ago
Created attachment 8784401 [details]
html file to open in firefox.

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:48.0) Gecko/20100101 Firefox/48.0
Build ID: 20160817112116

Steps to reproduce:

Type a text in a input field and put the cursor in the text.
Go to the next field with tabulation.
A tabulation CharCode(10) is inserted in the text.

In the code of the page, there is a listener on keypress for keyCode 9 (TAB) and an alert() function in the listener.
preventDefault() on event doesn't modify the behaviour.
See attachement for the html file.



Actual results:

A tabulation is inserted in the text (input field) in addition to the navigation by tab key.


Expected results:

Only the navigation by tab key to the next field.
(Reporter)

Updated

a year ago
Keywords: reproducible
OS: Unspecified → Windows 7
Hardware: Unspecified → x86_64
(Reporter)

Updated

a year ago
Component: Untriaged → Keyboard Navigation
(Reporter)

Updated

a year ago
Component: Keyboard Navigation → General
(Reporter)

Updated

a year ago
Component: General → DOM: Events
Product: Firefox → Core
(Reporter)

Comment 1

a year ago
Created attachment 8784733 [details]
testtab.html

Open the file in firefox and follow the instructions:
Enter text in the first or second input field and put the cursor inside the text. Then go to the next field with tab key. A tab will be inserted/added in the text.
Attachment #8784401 - Attachment is obsolete: true
Almost same bug as bug 1294536.
I confirmed it's fixed in the try build there.

could be just a dupe?
Status: UNCONFIRMED → NEW
Component: DOM: Events → Widget: Win32
Ever confirmed: true
Flags: needinfo?(masayuki)
See Also: → bug 1294536
Summary: Tabulation inserted in text input if keydown event is listened for keyCode 9 with alert() in listener → [non-e10s] Tabulation inserted in text input if keydown event is listened for keyCode 9 with alert() in listener
I think that for easier to find a bug which users to see, keep open this bug and close this bug when bug 1294536 is fixed.
Flags: needinfo?(masayuki)
tracking-e10s: --- → -
Priority: -- → P2
Whiteboard: tpi:+
I cannot reproduced with the latest Nightly build. Must be fixed by the fix of bug 1294536.
Status: NEW → RESOLVED
Last Resolved: a year ago
Depends on: 1294536
Resolution: --- → FIXED
See Also: bug 1294536
You need to log in before you can comment on or make changes to this bug.