parseFromString not working on SVG Windows Nightlies

RESOLVED WORKSFORME

Status

()

Core
XML
--
enhancement
RESOLVED WORKSFORME
16 years ago
16 years ago

People

(Reporter: Eric Murphy, Assigned: Daniel (Leaf) Nunes)

Tracking

({testcase})

Trunk
Future
x86
Windows 2000
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
parseFromString seems to be dying. This is on 0.9.9 trunk builds (I have not
tested non-trunk yet).

I need this fixed for 0.9.9 for a whiteboard application that uses this.
(Reporter)

Comment 1

16 years ago
Created attachment 73328 [details]
parse.html

It dies. alert doesn't show.
(Reporter)

Updated

16 years ago
Keywords: mozilla0.9.9, testcase
(Reporter)

Comment 2

16 years ago
Ok, doesn't work in regular nightlies either.
(Reporter)

Updated

16 years ago
Depends on: 92377
(Reporter)

Updated

16 years ago
No longer depends on: 92377
(Reporter)

Comment 3

16 years ago
Seems to depend on 92377 being fixed. The testcase no longer works after the 3rd.
Depends on: 92377
WFM in both my Mac trunk build and in a Mac 0.9.9 nightly downloaded from
ftp.mozilla.org (2002030805). Any messages in the JS console? Try a new profile
and/or deleting the component registry and xpti.dat.
Removing the bogus dependency, bug 92377 has already been fixed. It might have
caused this but there's no dependency.
No longer depends on: 92377
(Reporter)

Comment 6

16 years ago
OK, after more extensive testing, I figured out this only affects SVG Windows
builds. It says "parseFromString is not a fuction". This is very weird. Works
fine on Linux SVG builds.
Summary: parseFromString not working → parseFromString not working on SVG Windows Nightlies
Created attachment 73444 [details]
DOM category dump
Could you save attachment 73444 [details] locally and open it, and tell us if DOMParser is
in the "JavaScript global constructor" list or in the "JavaScript DOM class"
list? Also, did you try deleting your component registry and the xpti.dat files?
(Reporter)

Comment 9

16 years ago
It's in "JavaScript DOM class".

When I delete component.reg, then it works.

I tried the attachment again after deleting it, and it's still in the
"JavaScript DOM class".
I'll close this as INVALID because it gets fixed by deleting component.reg.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
(Reporter)

Comment 11

16 years ago
No. This is still a bug. Every new build I download, this has to be done. There
is something wrong.
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
(Reporter)

Comment 12

16 years ago
Also, this problem started happening immediately after 92377 path was checked
in. This is no coincidence either.
I can't reproduce.
The fix to bug 92377 invalidated component.reg. That file simply needs to be
deleted and it will be recreated. We will not fix this by coding... (unless we
had a situation with duplicate UUIDs, which I doubt).

If nightly builds contain invalid component.reg, they should be cleaned by hand.
This of course does not need to be done for clobber builds (I assumed all
nightly builds were clobber builds). Adding leaf to Cc. Hmm... where do you
download SVG enabled builds (if not mozilla.org)? You should inform them to
clobber their build once.
(Reporter)

Comment 15

16 years ago
There are nightly SVG builds on Mozilla.org. What is a clobber build?
clobber is a term we use in the make process which deletes all the old crap in
the tree so that next time you build you start from the beginning. 

Depend build is a build where you only build stuff that changed since the last
build.
Giving to leaf since this looks like it is some kind of
packaging/installer/zip/whatever problem.
Assignee: heikki → leaf
Status: REOPENED → NEW

Comment 18

16 years ago
no idea what an SVG build is, this bug needs to be assigned to whoever is doing
those builds.
Severity: blocker → enhancement
Target Milestone: --- → Future
(Reporter)

Comment 19

16 years ago
Latest nightly builds work.
Status: NEW → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → WORKSFORME

Updated

16 years ago
QA Contact: petersen → rakeshmishra
You need to log in before you can comment on or make changes to this bug.