Closed Bug 1298144 Opened 3 years ago Closed 2 years ago

fix clang-cl -Wreorder warnings in WindowsGamepad.cpp

Categories

(Core :: DOM: Core & HTML, defect, P3)

All
Windows
defect

Tracking

()

RESOLVED DUPLICATE of bug 1406380
Tracking Status
firefox58 --- fixed

People

(Reporter: froydnj, Unassigned)

References

(Blocks 1 open bug)

Details

clang-cl complains thusly:

11:00.42 c:/m-c/dom/gamepad/windows/WindowsGamepad.cpp(143,5):  warning: field 'hasDpad' will be initialized after field 'type' [-Wreorder]
11:00.42     hasDpad(aHasDpad),
11:00.42     ^
11:00.42 c:/m-c/dom/gamepad/windows/WindowsGamepad.cpp(161,20):  warning: field 'mXInputEnable' will be initialized after field 'mXInputGetState' [-Wreorder]
11:00.42                    mXInputEnable(nullptr),
11:00.42                    ^
11:00.42 c:/m-c/dom/gamepad/windows/WindowsGamepad.cpp(282,17):  warning: field 'mModule' will be initialized after field 'mHidD_GetProductString' [-Wreorder]
11:00.42   HIDLoader() : mModule(LoadLibraryW(L"hid.dll")),
11:00.42                 ^
Hi Nathan, I guess this is something we want to fix in the next months/release (P2); how does this sound to you?
Flags: needinfo?(nfroyd)
(In reply to Hsin-Yi Tsai [:hsinyi] from comment #1)
> Hi Nathan, I guess this is something we want to fix in the next
> months/release (P2); how does this sound to you?

That would be fine, thank you!
Flags: needinfo?(nfroyd)
Priority: -- → P2
Priority: P2 → P3
These clang-cl warnings were fixed by MinGW bug 1406380.
Blocks: buildwarning
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1406380
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.