Couple of telemetry probes seem to be semi-broken.

RESOLVED INVALID

Status

()

Firefox
Migration
RESOLVED INVALID
a year ago
a year ago

People

(Reporter: Dolske, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(firefox51 affected)

Details

(Reporter)

Description

a year ago
Bug 1276694 added two probes -- FX_STARTUP_MIGRATION_DATA_RECENCY and FX_STARTUP_MIGRATION_USED_RECENT_BROWSER. They landed on Nightly about halfway through the 50 cycle, and have not (currently) been uplifted to the 49 train.

Telemetry.mozilla.org doesn't seem to be fully reporting data for these probes. Not sure if this is a server problem or a probe problem. I'd normally suspect the latter as a starting point, but it's weird that Aurora-50 has data for one of the probes... I don't understand why it would have data, but Nightly-50 wouldn't, it got onto Aurora by riding the train.


For FX_STARTUP_MIGRATION_DATA_RECENCY:

Nothing shown for Nightly-50 (https://mzl.la/2bRqjUz)
Nothing shown for Nightly-51 (https://mzl.la/2bRr9R6)

Aurora-50 (https://mzl.la/2bRp8o8) shows data for the "ie" and "chrome" keys. But I would also very much expect there to be data for the "edge" key, and probably "safari" and "360se" as well (although those have such lower usage, I could plausibly believe there's actually no reported data. But Edge?)


For FX_STARTUP_MIGRATION_USED_RECENT_BROWSER:

Nothing shown for Nightly-50 (https://mzl.la/2bK8lG4)
Nothing shown for Nightly-51 (https://mzl.la/2bRpP0U)
Nothing shown for Aurora-50 (https://mzl.la/2bRqLCu)


We need to investigate and fix these probes. This data is critical to help understand if the browser we would have selected from automigrated is the same as users are manually choosing.
There *is* data. Under "advanced settings", you need to click "Don't sanitize".

The issue is that there is very little data, which isn't altogether terribly surprising because these probes are *only* used on initial startup migration, which is unlikely to happen on either nightly or aurora.
(Reporter)

Comment 2

a year ago
Ah, right you are.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.