Closed Bug 1298323 Opened 3 years ago Closed 3 years ago

Javascript error 'this._docShell is null' after closing [n+1]th window

Categories

(Toolkit :: Find Toolbar, defect, P1)

50 Branch
defect

Tracking

()

VERIFIED FIXED
mozilla51
Tracking Status
firefox50 + verified
firefox51 --- verified

People

(Reporter: mikedeboer, Assigned: mikedeboer)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

In bug 384458 I implemented a garbage collection mechanism, but that's doing too much: it destroys the Finder instance for the entire content process when only one window is closed (this firing the 'unload' event).
This is an unfortunate mistake, but easy to fix.
Flags: qe-verify+
Flags: firefox-backlog+
[Tracking Requested - why for this release]:
This was introduced in bug 384458, which we disabled, but didn't back out. Therefore we need to uplift this patch.
Comment on attachment 8785190 [details]
Bug 1298323 - do not destroy the Finder instance when only a single window closes in e10s mode, because that render the findbar useless.

https://reviewboard.mozilla.org/r/74484/#review72430
Attachment #8785190 - Flags: review?(jaws) → review+
Pushed by mdeboer@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2c5773f47093
do not destroy the Finder instance when only a single window closes in e10s mode, because that render the findbar useless. r=jaws
https://hg.mozilla.org/mozilla-central/rev/2c5773f47093
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla51
Hi Mike, should we uplift this fix to Beta50?
Flags: needinfo?(mdeboer)
Tracked since it's a recent regression.
Comment on attachment 8785190 [details]
Bug 1298323 - do not destroy the Finder instance when only a single window closes in e10s mode, because that render the findbar useless.

Approval Request Comment
[Feature/regressing bug #]: bug 384458
[User impact if declined]: Findbar may become unusable after a while.
[Describe test coverage new/current, TreeHerder]: landed on m-c, now on m-a, passing all tests.
[Risks and why]: minor, reverts back to the old mechanism of findbar lifetime management.
[String/UUID change made/needed]: n/a
Flags: needinfo?(mdeboer)
Attachment #8785190 - Flags: approval-mozilla-beta?
Comment on attachment 8785190 [details]
Bug 1298323 - do not destroy the Finder instance when only a single window closes in e10s mode, because that render the findbar useless.

Fixes a recent regression, Beta50+
Attachment #8785190 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Needs rebasing for Beta.
Flags: needinfo?(mdeboer)
To verify this bug, you need to perform the following steps:

1. Start Firefox and open two windows
2. In each window, use the findbar at least once by typing in its input box
3. Close one of the windows
4. In the window that's still open, close & re-open the findbar and use it again by typing in its input box
5. No error should appear in the Browser Console.
Reproduced the error from old Nightly (2016-09-26)
> TypeError: this._docShell is nullFinder.jsm:64:5

Verified that using Firefox 50 beta 3 and latest Developer Edition 51.0a2 across platforms (Ubuntu 16.04 32-bit, Mac OS X 10.10.5 and Windows 10 64-bit).
Status: RESOLVED → VERIFIED
Flags: qe-verify+
(In reply to Bogdan Maris, QA [:bogdan_maris] from comment #14)
> Reproduced the error from old Nightly (2016-09-26)

Ups, actually I tested on Nightly from 2016-_08_-26, sorry for this.
You need to log in before you can comment on or make changes to this bug.