crashes on media player start

RESOLVED FIXED

Status

()

Core
Audio/Video: Playback
P3
critical
RESOLVED FIXED
a year ago
a year ago

People

(Reporter: Ulrich Teichert, Unassigned)

Tracking

({crash, regression})

48 Branch
x86
Linux
crash, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (X11; Linux i686; rv:47.0) Gecko/20100101 Firefox/47.0
Build ID: 20160623154057

Steps to reproduce:

Linux, 32 bit:
Go to https://www.discogs.com/EA80-Vorsicht-Schreie/master/24936, try to play a video...


Actual results:

crash with out crashdump, on stderr:

ATTENTION: default value of option force_s3tc_enable overridden by environment.
ExceptionHandler::GenerateDump cloned child 3874
ExceptionHandler::SendContinueSignalToChild sent continue signal to child
ExceptionHandler::WaitForContinueSignal waiting for continue signal...
Gtk-Message: GtkDialog mapped without a transient parent. This is discouraged.


Expected results:

Play a video
(Reporter)

Updated

a year ago
OS: Unspecified → Linux
Hardware: Unspecified → x86
(Reporter)

Comment 1

a year ago
Oh, ah forgot to add that 47.0.1 works perfectly on the same hardware and site.
Severity: normal → critical
Component: Untriaged → Audio/Video: Playback
Keywords: crash, stackwanted
Product: Firefox → Core
Keywords: regression, regressionwindow-wanted
Please post the output of about:support
This is likely lack of SSE2 support on your (presumably Althon XP) CPU. Can you please paste processor 0 from the following command:

$ cat /proc/cpuinfo
Flags: needinfo?(giles)
Keywords: regressionwindow-wanted, stackwanted
It would also help to know whether you're using a build from Firefox, from your Linux distro, or from some other source.
Depends on: 1277359
Flags: needinfo?(giles) → needinfo?(ulrich.teichert)
(Reporter)

Comment 5

a year ago
Easiest first, output from /proc/cpuinfo:

processor       : 0
vendor_id       : AuthenticAMD
cpu family      : 6
model           : 6
model name      : AMD Athlon(tm) XP 2000+
stepping        : 2
cpu MHz         : 1666.423
cache size      : 256 KB
physical id     : 0
siblings        : 1
core id         : 0
cpu cores       : 1
apicid          : 0
initial apicid  : 0
fdiv_bug        : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 1
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 sep mtrr pge mca cmov pat pse36 mmx fxsr sse syscall mmxext 3dnowext 3dnow vmmcall
bogomips        : 3332.84
clflush size    : 32
cache_alignment : 32
address sizes   : 34 bits physical, 32 bits virtual
power management: ts

Is a non-SSE2 CPU not supported anymore?
(Reporter)

Comment 6

a year ago
about:support output:

Application Basics
------------------

Name: Firefox
Version: 48.0.2
Build ID: 20160823121617
Update Channel: release
User Agent: Mozilla/5.0 (X11; Linux i686; rv:48.0) Gecko/20100101 Firefox/48.0
OS: Linux 3.16.0-4-686-pae x86
Multiprocess Windows: 0/1 (Disabled)
Safe Mode: false

Crash Reports for the Last 3 Days
---------------------------------

All Crash Reports

Extensions
----------

Name: Firebug
Version: 2.0.17
Enabled: true
ID: firebug@software.joehewitt.com

Name: Firefox Hello
Version: 1.4.4
Enabled: true
ID: loop@mozilla.org

Name: Multi-process staged rollout
Version: 1.1
Enabled: true
ID: e10srollout@mozilla.org

Name: Pocket
Version: 1.0.4
Enabled: true
ID: firefox@getpocket.com

Graphics
--------

Features
Compositing: Basic
Asynchronous Pan/Zoom: none
WebGL Renderer: X.Org R300 Project -- Gallium 0.4 on ATI RV350
Hardware H264 Decoding: No
GPU #1
Active: Yes
Description: X.Org R300 Project -- Gallium 0.4 on ATI RV350
Vendor ID: X.Org R300 Project
Device ID: Gallium 0.4 on ATI RV350
Driver Version: 2.1 Mesa 10.3.2

Diagnostics
AzureCanvasAccelerated: 0
AzureCanvasBackend: skia
AzureContentBackend: cairo
AzureFallbackCanvasBackend: none
CairoUseXRender: 0


Important Modified Preferences
------------------------------

accessibility.blockautorefresh: true
accessibility.browsewithcaret: true
accessibility.typeaheadfind.flashBar: 0
browser.cache.disk.capacity: 102400
browser.cache.disk.filesystem_reported: 1
browser.cache.disk.hashstats_reported: 1
browser.cache.disk.smart_size_cached_value: 153600
browser.cache.disk.smart_size.first_run: false
browser.cache.disk.smart_size.use_old_max: false
browser.cache.frecency_experiment: 2
browser.download.folderList: 2
browser.download.importedFromSqlite: true
browser.download.manager.closeWhenDone: true
browser.download.useDownloadDir: false
browser.history_expire_days.mirror: 180
browser.places.smartBookmarksVersion: 8
browser.search.update: false
browser.sessionstore.upgradeBackup.latestBuildID: 20160823121617
browser.startup.homepage: http://www.ulrich-teichert.org/
browser.startup.homepage_override.buildID: 20160823121617
browser.startup.homepage_override.mstone: 48.0.2
browser.tabs.warnOnClose: false
browser.urlbar.daysBeforeHidingSuggestionsPrompt: 1
browser.urlbar.lastSuggestionsPromptDate: 20160829
browser.urlbar.trimURLs: false
dom.apps.reset-permissions: true
dom.max_script_run_time: 0
dom.mozApps.used: true
dom.w3c_touch_events.expose: false
extensions.lastAppVersion: 48.0.2
font.internaluseonly.changed: true
font.minimum-size.x-western: 12
gfx.blacklist.suggested-driver-version: <Anything with EXT_texture_from_pixmap support>
gfx.crash-guard.glcontext.appVersion: 45.0.2
gfx.crash-guard.glcontext.deviceID: Gallium 0.4 on ATI RV350
gfx.crash-guard.glcontext.driverVersion: 2.1 Mesa 10.3.2
gfx.crash-guard.status.glcontext: 2
media.gmp-gmpopenh264.abi: x86-gcc3
media.gmp-gmpopenh264.lastUpdate: 1471543238
media.gmp-gmpopenh264.version: 1.6
media.gmp-manager.buildID: 20160623154057
media.gmp-manager.lastCheck: 1472495966
media.gmp.storage.version.observed: 1
network.cookie.prefsMigrated: true
network.predictor.cleaned-up: true
places.database.lastMaintenance: 1472149315
places.history.expiration.transient_current_max_pages: 2212
plugin.disable_full_page_plugin_for_types: application/pdf
plugin.importedState: true
plugin.state.libgnome-shell-browser-plugin: 0
print.print_bgcolor: false
print.print_bgimages: false
print.print_colorspace: default
print.print_downloadfonts: false
print.print_duplex: 0
print.print_evenpages: true
print.print_in_color: true
print.print_margin_bottom: 0.500000012107193
print.print_margin_left: 0.500000012107193
print.print_margin_right: 0.500000012107193
print.print_margin_top: 0.500000012107193
print.print_oddpages: true
print.print_orientation: 0
print.print_page_delay: 50
print.print_paper_data: 0
print.print_paper_height: 297.00
print.print_paper_name: iso_a4
print.print_paper_size_type: 1
print.print_paper_size_unit: 1
print.print_paper_width: 210.00
print.print_plex_name: default
print.print_resolution: 600
print.print_resolution_name: default
print.print_scaling: 1.00
print.print_shrink_to_fit: true
print.print_to_file: false
print.print_unwriteable_margin_bottom: 56
print.print_unwriteable_margin_left: 25
print.print_unwriteable_margin_right: 25
print.print_unwriteable_margin_top: 25
print.tmp.printerfeatures.arbas.can_change_colorspace: false
print.tmp.printerfeatures.arbas.can_change_downloadfonts: false
print.tmp.printerfeatures.arbas.can_change_jobtitle: false
print.tmp.printerfeatures.arbas.can_change_num_copies: true
print.tmp.printerfeatures.arbas.can_change_orientation: true
print.tmp.printerfeatures.arbas.can_change_paper_size: true
print.tmp.printerfeatures.arbas.can_change_plex: false
print.tmp.printerfeatures.arbas.can_change_printincolor: true
print.tmp.printerfeatures.arbas.can_change_resolution: false
print.tmp.printerfeatures.arbas.can_change_spoolercommand: false
print.tmp.printerfeatures.arbas.colorspace.0.name: default
print.tmp.printerfeatures.arbas.colorspace.count: 1
print.tmp.printerfeatures.arbas.has_special_printerfeatures: true
print.tmp.printerfeatures.arbas.orientation.0.name: portrait
print.tmp.printerfeatures.arbas.orientation.1.name: landscape
print.tmp.printerfeatures.arbas.orientation.count: 2
print.tmp.printerfeatures.arbas.paper.0.height_mm: 210
print.tmp.printerfeatures.arbas.paper.0.is_inch: false
print.tmp.printerfeatures.arbas.paper.0.name: A5
print.tmp.printerfeatures.arbas.paper.0.width_mm: 148
print.tmp.printerfeatures.arbas.paper.1.height_mm: 297
print.tmp.printerfeatures.arbas.paper.1.is_inch: false
print.tmp.printerfeatures.arbas.paper.1.name: A4
print.tmp.printerfeatures.arbas.paper.1.width_mm: 210
print.tmp.printerfeatures.arbas.paper.2.height_mm: 420
print.tmp.printerfeatures.arbas.paper.2.is_inch: false
print.tmp.printerfeatures.arbas.paper.2.name: A3
print.tmp.printerfeatures.arbas.paper.2.width_mm: 297
print.tmp.printerfeatures.arbas.paper.3.height_mm: 279
print.tmp.printerfeatures.arbas.paper.3.is_inch: true
print.tmp.printerfeatures.arbas.paper.3.name: Letter
print.tmp.printerfeatures.arbas.paper.3.width_mm: 215
print.tmp.printerfeatures.arbas.paper.4.height_mm: 355
print.tmp.printerfeatures.arbas.paper.4.is_inch: true
print.tmp.printerfeatures.arbas.paper.4.name: Legal
print.tmp.printerfeatures.arbas.paper.4.width_mm: 215
print.tmp.printerfeatures.arbas.paper.5.height_mm: 431
print.tmp.printerfeatures.arbas.paper.5.is_inch: true
print.tmp.printerfeatures.arbas.paper.5.name: Tabloid
print.tmp.printerfeatures.arbas.paper.5.width_mm: 279
print.tmp.printerfeatures.arbas.paper.6.height_mm: 254
print.tmp.printerfeatures.arbas.paper.6.is_inch: true
print.tmp.printerfeatures.arbas.paper.6.name: Executive
print.tmp.printerfeatures.arbas.paper.6.width_mm: 190
print.tmp.printerfeatures.arbas.paper.count: 7
print.tmp.printerfeatures.arbas.plex.0.name: default
print.tmp.printerfeatures.arbas.plex.count: 1
print.tmp.printerfeatures.arbas.resolution.0.name: default
print.tmp.printerfeatures.arbas.resolution.count: 1
print.tmp.printerfeatures.arbas.supports_colorspace_change: false
print.tmp.printerfeatures.arbas.supports_downloadfonts_change: false
print.tmp.printerfeatures.arbas.supports_jobtitle_change: false
print.tmp.printerfeatures.arbas.supports_orientation_change: true
print.tmp.printerfeatures.arbas.supports_paper_size_change: true
print.tmp.printerfeatures.arbas.supports_plex_change: false
print.tmp.printerfeatures.arbas.supports_printincolor_change: true
print.tmp.printerfeatures.arbas.supports_resolution_change: false
print.tmp.printerfeatures.arbas.supports_spoolercommand_change: false
print.tmp.printerfeatures.CUPS/arbas.can_change_colorspace: false
print.tmp.printerfeatures.CUPS/arbas.can_change_downloadfonts: false
print.tmp.printerfeatures.CUPS/arbas.can_change_jobtitle: false
print.tmp.printerfeatures.CUPS/arbas.can_change_num_copies: true
print.tmp.printerfeatures.CUPS/arbas.can_change_orientation: true
print.tmp.printerfeatures.CUPS/arbas.can_change_paper_size: true
print.tmp.printerfeatures.CUPS/arbas.can_change_plex: false
print.tmp.printerfeatures.CUPS/arbas.can_change_printincolor: true
print.tmp.printerfeatures.CUPS/arbas.can_change_resolution: false
print.tmp.printerfeatures.CUPS/arbas.can_change_spoolercommand: false
print.tmp.printerfeatures.CUPS/arbas.colorspace.0.name: default
print.tmp.printerfeatures.CUPS/arbas.colorspace.count: 1
print.tmp.printerfeatures.CUPS/arbas.has_special_printerfeatures: true
print.tmp.printerfeatures.CUPS/arbas.orientation.0.name: portrait
print.tmp.printerfeatures.CUPS/arbas.orientation.1.name: landscape
print.tmp.printerfeatures.CUPS/arbas.orientation.count: 2
print.tmp.printerfeatures.CUPS/arbas.paper.0.height_mm: 210
print.tmp.printerfeatures.CUPS/arbas.paper.0.is_inch: false
print.tmp.printerfeatures.CUPS/arbas.paper.0.name: A5
print.tmp.printerfeatures.CUPS/arbas.paper.0.width_mm: 148
print.tmp.printerfeatures.CUPS/arbas.paper.1.height_mm: 297
print.tmp.printerfeatures.CUPS/arbas.paper.1.is_inch: false
print.tmp.printerfeatures.CUPS/arbas.paper.1.name: A4
print.tmp.printerfeatures.CUPS/arbas.paper.1.width_mm: 210
print.tmp.printerfeatures.CUPS/arbas.paper.2.height_mm: 420
print.tmp.printerfeatures.CUPS/arbas.paper.2.is_inch: false
print.tmp.printerfeatures.CUPS/arbas.paper.2.name: A3
print.tmp.printerfeatures.CUPS/arbas.paper.2.width_mm: 297
print.tmp.printerfeatures.CUPS/arbas.paper.3.height_mm: 279
print.tmp.printerfeatures.CUPS/arbas.paper.3.is_inch: true
print.tmp.printerfeatures.CUPS/arbas.paper.3.name: Letter
print.tmp.printerfeatures.CUPS/arbas.paper.3.width_mm: 215
print.tmp.printerfeatures.CUPS/arbas.paper.4.height_mm: 355
print.tmp.printerfeatures.CUPS/arbas.paper.4.is_inch: true
print.tmp.printerfeatures.CUPS/arbas.paper.4.name: Legal
print.tmp.printerfeatures.CUPS/arbas.paper.4.width_mm: 215
print.tmp.printerfeatures.CUPS/arbas.paper.5.height_mm: 431
print.tmp.printerfeatures.CUPS/arbas.paper.5.is_inch: true
print.tmp.printerfeatures.CUPS/arbas.paper.5.name: Tabloid
print.tmp.printerfeatures.CUPS/arbas.paper.5.width_mm: 279
print.tmp.printerfeatures.CUPS/arbas.paper.6.height_mm: 254
print.tmp.printerfeatures.CUPS/arbas.paper.6.is_inch: true
print.tmp.printerfeatures.CUPS/arbas.paper.6.name: Executive
print.tmp.printerfeatures.CUPS/arbas.paper.6.width_mm: 190
print.tmp.printerfeatures.CUPS/arbas.paper.count: 7
print.tmp.printerfeatures.CUPS/arbas.plex.0.name: default
print.tmp.printerfeatures.CUPS/arbas.plex.count: 1
print.tmp.printerfeatures.CUPS/arbas.resolution.0.name: default
print.tmp.printerfeatures.CUPS/arbas.resolution.count: 1
print.tmp.printerfeatures.CUPS/arbas.supports_colorspace_change: false
print.tmp.printerfeatures.CUPS/arbas.supports_downloadfonts_change: false
print.tmp.printerfeatures.CUPS/arbas.supports_jobtitle_change: false
print.tmp.printerfeatures.CUPS/arbas.supports_orientation_change: true
print.tmp.printerfeatures.CUPS/arbas.supports_paper_size_change: true
print.tmp.printerfeatures.CUPS/arbas.supports_plex_change: false
print.tmp.printerfeatures.CUPS/arbas.supports_printincolor_change: true
print.tmp.printerfeatures.CUPS/arbas.supports_resolution_change: false
print.tmp.printerfeatures.CUPS/arbas.supports_spoolercommand_change: false
privacy.donottrackheader.enabled: true
privacy.sanitize.migrateClearSavedPwdsOnExit: true
privacy.sanitize.migrateFx3Prefs: true
privacy.sanitize.timeSpan: 0
security.warn_viewing_mixed: false
services.sync.declinedEngines:
storage.vacuum.last.index: 1
storage.vacuum.last.places.sqlite: 1472149314

Important Locked Preferences
----------------------------

JavaScript
----------

Incremental GC: true

Accessibility
-------------

Activated: false
Prevent Accessibility: 0

Library Versions
----------------

NSPR
Expected minimum version: 4.12
Version in use: 4.12

NSS
Expected minimum version: 3.24 Basic ECC
Version in use: 3.24 Basic ECC

NSSSMIME
Expected minimum version: 3.24 Basic ECC
Version in use: 3.24 Basic ECC

NSSSSL
Expected minimum version: 3.24 Basic ECC
Version in use: 3.24 Basic ECC

NSSUTIL
Expected minimum version: 3.24
Version in use: 3.24

Experimental Features
---------------------

Sandbox
-------

Seccomp-BPF (System Call Filtering): true
Seccomp Thread Synchronization: false
User Namespaces for privileged processes: true
User Namespaces: false
Media Plugin Sandboxing: true
(Reporter)

Comment 7

a year ago
It's the offical 48.0.2 build from mozilla on an up-to-date debian 8.5.
Flags: needinfo?(ulrich.teichert)
(In reply to Ulrich Teichert from comment #7)
> It's the offical 48.0.2 build from mozilla on an up-to-date debian 8.5.

Ok, thanks for the info!

We dropped support for non-SSE2 CPUs in Firefox 49. That's a hard decision for Windows, for Linux there's still some discussion (bug 1274196) since Debian will (I believe) want to maintain support in their builds. But because of that I didn't fix this regression in 48. Sorry about that.
The build from here should work http://mozilla.debian.net/
I've done a test build which I believe addresses the issue. If you'd be willing to try it on your machine and confirm whether I was successful, that would be very helpful. Please try:

https://archive.mozilla.org/pub/firefox/try-builds/rgiles@mozilla.com-03bbe8f9911ea876fb53d7a1b2f3e03b0fc5fa81/try-linux/firefox-51.0a1.en-US.linux-i686.tar.bz2
Flags: needinfo?(ulrich.teichert)
(Reporter)

Comment 11

a year ago
Hi,

both builds, the one from http://mozilla.debian.net/ and your nightly build are working on my box. So, as far as I´m concered, I would vote for keeping support for non-SSE2 32 bit CPUs on Linux ;-)

Thanks for all the support,
CU,
Uli
Flags: needinfo?(ulrich.teichert)
Great, thanks for confirming. Hopefully we can fix the regression for at least a few more releases starting with 49.
Priority: -- → P3
I believe this is addressed now for the upcoming 49 and a few subsequent releases. Thanks for the report!
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.