radio button unreadable because of dark background set on it by page

RESOLVED DUPLICATE of bug 79719

Status

()

Core
Layout: Form Controls
RESOLVED DUPLICATE of bug 79719
16 years ago
16 years ago

People

(Reporter: Devoti Paolo, Assigned: rods (gone))

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.9+) Gecko/20020308
BuildID:    2002030803

look the "start here" selection. It's black on dark blu.

Reproducible: Always
Steps to Reproduce:
1.open url http://www.carmax.com/

Actual Results:  start here selection unreadable black on dark blu
Expected Results:  no inherited background, always white

Comment 1

16 years ago
dup of bug 79719?
Um... that's not an inherited background:

<input style="background-color: #000099;" type="radio" name="NewUsed" value="1"
checked>

We should either make the background !important in forms.css or send this to evang.
Assignee: asa → rods
Status: UNCONFIRMED → NEW
Component: Browser-General → HTML Form Controls
Ever confirmed: true
QA Contact: doronr → madhur
Summary: radio button unreadable because of inherited dark background → radio button unreadable because of dark background set on it by page

Comment 3

16 years ago
Just because a web 'designer' is stupid doesn't mean that nobody should be able
to change the background of form elements.
If I make a page with the same color for background and foreground, your
solution is that nobody can change the background-color for that element? You
better start removing all the CSS suport right now.

Please, move this bug to evangelism.
> You better start removing all the CSS suport right now.

One more time.  Form controls are not subject to CSS because there is no way to
describe them in CSS.  Applying CSS to form controls is completely undefined. 
Thus there is something to be said for being compatible with other browsers
here, especially since one can change the background of the radio buttons but
not the foreground as things stand.  So a well-meaning web designer could set
both and it would _still_ not be usable.

All that said, I agree that this should be evang.  But that's Rod's call.

Comment 5

16 years ago
I believe this bug is plain invalid, like bug 79719. From comment by mpt:

"Currently, we draw radio buttons entirely in CSS. We use the
`-moz-border-radius' property to determine that they're round rather than 
square, we use the `border' property to draw their borders, and we use the 
`background' property to fill in the space inside the borders (since that's 
what a `background' is, in CSS).

That last detail is why changing the `background' property for a radio button 
will change the color inside the border, rather than outside. This is perfectly 
reasonable behavior, and it will remain the case until we get XBLified form 
controls -- whereupon form controls will probably be quite a bit less stylable 
than they are now. Resolving as invalid."

Comment 6

16 years ago
One more thing: To evangelize every radio-button on web just because Mozilla for
now has a CSS approach to them, doesn't seem at all practical.
Resolving as duplicate of bug 79719.

*** This bug has been marked as a duplicate of 79719 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.