Crash in mozilla::layers::APZEventState::ProcessAPZStateChange

RESOLVED FIXED in Firefox 51

Status

()

Core
Panning and Zooming
P1
critical
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: marcia, Assigned: rhunt)

Tracking

({crash, regression})

51 Branch
mozilla51
Unspecified
All
crash, regression
Points:
---

Firefox Tracking Flags

(firefox48 unaffected, firefox49 unaffected, firefox50 unaffected, firefox51 fixed)

Details

(Whiteboard: [gfx-noted], crash signature)

Attachments

(1 attachment)

This bug was filed from the Socorro interface and is 
report bp-8bb1e627-1793-4304-b0ee-150302160827.
=============================================================

Seen while looking at nightly crash stats: http://bit.ly/2cioCUF. Crash affects Windows and Mac.

Adding ni on kats to weigh in since it looks it touches code in an area he works in.
Flags: needinfo?(bugmail)
As of bug 1289650 mAPZEventState gets nulled out in the ChromeProcessController before the object is destroyed, so we need to add null checks. This crash looks like it happens because we invoke a function on a destroyed APZEventState object during shutdown. Assigning to Ryan; the patch should be pretty straightforward. Crash-stats is already showing 20 of these crashes so we should fix it soonish.
Assignee: nobody → rhunt
Blocks: 1289650
status-firefox50: --- → unaffected
Flags: needinfo?(bugmail)
Keywords: regression
Priority: -- → P1
Whiteboard: [gfx-noted]
Version: Trunk → 51 Branch
18 crashes on Mac in Nightly 20160826030226, making it the #2 Mac crash. (On Windows it's #36 in that Nightly, with 4 crashes so far.)
(Assignee)

Comment 3

2 years ago
Created attachment 8785818 [details] [diff] [review]
apz-event-state.patch
Attachment #8785818 - Flags: review?(bugmail)
Attachment #8785818 - Flags: review?(bugmail) → review+
(Assignee)

Updated

2 years ago
Keywords: checkin-needed

Comment 4

2 years ago
Pushed by kgupta@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/a36f77d091f6
Check if mAPZEventState is null. r=kats
Keywords: checkin-needed
status-firefox48: --- → unaffected
status-firefox49: --- → unaffected

Comment 5

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/a36f77d091f6
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox51: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla51
You need to log in before you can comment on or make changes to this bug.