Closed Bug 1298684 Opened 5 years ago Closed 5 years ago

Pasting after a backtick pastes twice on French input

Categories

(Core :: Widget: Cocoa, defect)

48 Branch
x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1280053

People

(Reporter: jnizet, Unassigned)

References

Details

(Keywords: inputmethod, regression)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:48.0) Gecko/20100101 Firefox/48.0
Build ID: 20160817112116

Steps to reproduce:

- copy some text (example: "hello")
- go to any page containing a text input or text area
- enter a backtick (`) in the input or textarea, and don't press the space bar after this backtick
- paste (using Cmd-V)




Actual results:

The text input or area now contains `hellohello: the text has been pasted twice.


Expected results:

The text input or area should contain `hello: the text should be pasted just once.
OS: Unspecified → Mac OS X
Hardware: Unspecified → x86
I cannot reproduce the issue in the search field on this page.
Can you provide the URL of the page the issue happens?
Also, does the issue happen on safe mode and clean profile?
Flags: needinfo?(jnizet)
It does happen on this page. 
It does happen in safe mode. 
It does happen on a clean profile.
It does happen when opening a file just containing

    <html><head></head><body><textarea></textarea></body></html>

Additional, maybe helpful information: I'm using OSX 10.11.5 (15F34), French locale, with a French keyboard. After I have pasted the test, hitting Cmd-Z "unpastes" the second "hello", hitting Cmd-Z a second time "unpastes" the first "hello". So there are two successive paste actions being made.

It doesn't happen on system text boxes and in Chrome where, after a back-tick has been typed, Cmd-V doesn't do anything other than "accepting" the backtick, and a second Cmd-V actually pastes the copied text a single time. It doesn't happen in Chrome either, where the same behavior is observed.
Thanks.
confirmed the issue on "Français" input.
Status: UNCONFIRMED → NEW
Component: Untriaged → Widget: Cocoa
Ever confirmed: true
Flags: needinfo?(jnizet)
Keywords: inputmethod
Product: Firefox → Core
Summary: Pasting after a backtick pastes twice → Pasting after a backtick pastes twice on French input
Masayuki, could you take a look?
Flags: needinfo?(masayuki)
Must be a dup of bug 1280053, no?
Flags: needinfo?(masayuki)
Thanks, Masayuki!

JB Nizet, could you confirm that this issue no longer occurs in the latest nightly? You can download it here:
https://nightly.mozilla.org/

Thanks!
Flags: needinfo?(jnizet)
Thanks for checking!

Reporter, please reopen and provide more info in case you still experience this issue on a recent nightly. Thank you!
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: needinfo?(jnizet)
Resolution: --- → DUPLICATE
Duplicate of bug: 1280053
You need to log in before you can comment on or make changes to this bug.