Devtools fail to inspect objects that inherit from a proxy

RESOLVED DUPLICATE of bug 1380506

Status

()

Firefox
Developer Tools: Object Inspector
RESOLVED DUPLICATE of bug 1380506
2 years ago
6 months ago

People

(Reporter: Oriol, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
Since bug 1274657, devtools do not execute traps when inspecting a proxy.

However, they still do it when inspecting a normal object which inherits from a proxy one.

For example, run this in the console:

    var r = Proxy.revocable({}, {});
    r.revoke();
    Object.create(r.proxy);

Both previewing it in the console or inspecting it in variablesview produces errors.
(Reporter)

Comment 1

6 months ago
This is a mix of various bugs, mostly bug 1380506.
Status: NEW → RESOLVED
Last Resolved: 6 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1380506
You need to log in before you can comment on or make changes to this bug.